Bug 856278 - entitlement-check.py is happy with old certificate
entitlement-check.py is happy with old certificate
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
550
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
Martin Minar
:
Depends On:
Blocks: sat560-upgrades
  Show dependency treegraph
 
Reported: 2012-09-11 11:42 EDT by Matej Kollar
Modified: 2016-07-03 20:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: rhn-upgrade-5.6.0.13-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 15:25:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matej Kollar 2012-09-11 11:42:58 EDT
Description of problem:

  There is step during upgrade preparation process
  (described in /etc/sysconfig/rhn/satellite-upgrade/doc/preparations.txt
  installed by rhn-upgrade) where certificate is checked.
  (Main focus is probably on sufficiency of entitlements
  for all currently registered machines.) It goes like this:

  > Run:
  > 
  >     cd /etc/sysconfig/rhn/satellite-upgrade/scripts
  >     ./entitlement-check.py --rhn-cert=~/new.cert
  > 
  > where ~/new.cert is the path to the new entitlement certificate you will use
  > during the upgrade (this was requested in step #1 above).

  Supplying entitlement-check.py with path to old (i.e. 541, ... actuallu used)
  certificate yealds no warning.

Version-Release number of selected component (if applicable):

  rhn-upgrade-5.5.0.16-1(.el5sat)

How reproducible: always/deterministic

Steps to Reproduce:

  1. install rhn-upgrade
  2. run entitlement-check.py for old certificate
  
Actual results:

  Test passes, no warning issued.

Expected results:

  Test at least warning is printed, informing user that his certificate
  is not intended to work with new Satellite.
Comment 3 Clifford Perry 2013-10-01 15:25:38 EDT
Satellite 5.6 has been released. This bug tracked under Upgrades. 

This bug either was VERIFIED or RELEASE_PENDING (re-verified prior shortly before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1393.html

Note You need to log in before you can comment on or make changes to this bug.