Bug 856320 - emoji-table input does not work well, some phrases are impossible to input.
emoji-table input does not work well, some phrases are impossible to input.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus-table (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike FABIAN
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 14:53 EDT by Mike FABIAN
Modified: 2012-11-28 06:54 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 06:54:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ibus-table-1.4.99.20120907-improve-chinese-category-check.patch (1.95 KB, patch)
2012-09-11 15:13 EDT, Mike FABIAN
no flags Details | Diff

  None (edit)
Description Mike FABIAN 2012-09-11 14:53:01 EDT
For example, emoji-table.txt (from the ibus-table-others package)
contains:

    bishi	╭∩╮(︶︿︶)╭∩╮鄙视你!	0

so typing "bishi" should give

    ╭∩╮(︶︿︶)╭∩╮鄙视你!

as one of the candidates.

But it doesn’t do that, in fact typing "bishi" gives:

   (⊙x⊙;)[视力表]┫♀旦 ̄)σ(呃……)

which comes from:

    bizui	(⊙x⊙;)	0

followed by

    shili	[视力表]┫♀旦 ̄)σ(呃……)	0

The problem is caused by a bug in the ibus-table package, classifying
╭∩╮(︶︿︶)╭∩╮鄙视你! as traditional Chinese (although it is
clearly simplified Chinese) just because some of the non-Chinese
characters in that phrase cannot be converted to gb2312 but happen to
be convertible to big5hkscs.

Therefore, ╭∩╮(︶︿︶)╭∩╮鄙视你! does not appear in the list
of matches while typing "bishi", when "bi" is typed
the list of matches is already down to (⊙x⊙;) which is then
autocomitted and continuing to type the "shi" selects
[视力表]┫♀旦 ̄)σ(呃……)

This can be fixed by improving the detection of simplified and
traditonal Chinese while building the tables by ignoring
all non-Chinese characters when doing the detection.
Comment 1 Mike FABIAN 2012-09-11 15:13:15 EDT
Created attachment 611892 [details]
ibus-table-1.4.99.20120907-improve-chinese-category-check.patch

Patch to fix the problem.
Comment 3 Mike FABIAN 2012-09-11 16:29:55 EDT
Mathieu, can you check that this does not break bug#834971 again?

It should not break it but better make sure.
Comment 4 Fedora Update System 2012-09-13 09:09:01 EDT
ibus-table-1.4.99.20120907-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-table-1.4.99.20120907-2.fc18
Comment 5 Fedora Update System 2012-09-13 12:46:10 EDT
Package ibus-table-1.4.99.20120907-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-table-1.4.99.20120907-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13918/ibus-table-1.4.99.20120907-2.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-11-12 03:01:52 EST
ibus-table-1.4.99.20120907-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-table-1.4.99.20120907-3.fc17
Comment 7 Fedora Update System 2012-11-13 07:50:50 EST
ibus-table-1.4.99.20121113-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-table-1.4.99.20121113-1.fc17
Comment 8 Fedora Update System 2012-11-28 06:54:08 EST
ibus-table-1.4.99.20121113-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.