Bug 856356 - [ERROR] The driver 'openstack' is unknown or not installed
[ERROR] The driver 'openstack' is unknown or not installed
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: deltacloud-core (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Michal Fojtik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 16:40 EDT by Jon Thomas
Modified: 2013-08-01 00:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 00:57:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Thomas 2012-09-11 16:40:50 EDT
Tried to load the openstack driver on f17 and got:

# deltacloudd -i openstack
Starting Deltacloud API :: openstack :: http://127.0.0.1:35357/v2.0/ :: http://localhost:3001/api

/usr/share/deltacloud-core/lib/deltacloud/helpers/driver_helper.rb:53:in `rescue in driver': [ERROR] The driver 'openstack' is unknown or not installed (/usr/share/deltacloud-core/lib/deltacloud/drivers/openstack/openstack_driver.rb) (RuntimeError)

cannot load such file -- openstack
	from /usr/share/deltacloud-core/lib/deltacloud/helpers/driver_helper.rb:48:in `driver'
	from /usr/share/deltacloud-core/lib/deltacloud/collections/images.rb:21:in `block in <class:Images>'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:334:in `call'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:334:in `block in generate'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:332:in `each'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:332:in `generate'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:231:in `operation'
	from /usr/share/deltacloud-core/lib/deltacloud/collections/images.rb:32:in `block in <class:Images>'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:106:in `class_eval'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:106:in `generate'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/dsl.rb:36:in `block in collection'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base_collection.rb:56:in `rescue in collection_class'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base_collection.rb:53:in `collection_class'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/dsl.rb:34:in `collection'
	from /usr/share/deltacloud-core/lib/deltacloud/collections/images.rb:29:in `<class:Images>'
	from /usr/share/deltacloud-core/lib/deltacloud/collections/images.rb:17:in `<module:Collections>'
	from /usr/share/deltacloud-core/lib/deltacloud/collections/images.rb:16:in `<top (required)>'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/deltacloud-core/lib/deltacloud/collections.rb:38:in `block in <module:Collections>'
	from /usr/share/deltacloud-core/lib/deltacloud/collections.rb:37:in `each'
	from /usr/share/deltacloud-core/lib/deltacloud/collections.rb:37:in `<module:Collections>'
	from /usr/share/deltacloud-core/lib/deltacloud/collections.rb:27:in `<module:Deltacloud>'
	from /usr/share/deltacloud-core/lib/deltacloud/collections.rb:17:in `<top (required)>'
	from /usr/share/deltacloud-core/lib/deltacloud/server.rb:28:in `require_relative'
	from /usr/share/deltacloud-core/lib/deltacloud/server.rb:28:in `<top (required)>'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/deltacloud-core/lib/deltacloud_rack.rb:44:in `require_frontend!'
	from /usr/share/deltacloud-core/config.ru:61:in `block in <main>'
	from /usr/share/gems/gems/rack-1.4.0/lib/rack/builder.rb:51:in `instance_eval'
	from /usr/share/gems/gems/rack-1.4.0/lib/rack/builder.rb:51:in `initialize'
	from /usr/share/deltacloud-core/config.ru:1:in `new'
	from /usr/share/deltacloud-core/config.ru:1:in `<main>'
	from /usr/share/gems/gems/thin-1.3.1/lib/rack/adapter/loader.rb:36:in `eval'
	from /usr/share/gems/gems/thin-1.3.1/lib/rack/adapter/loader.rb:36:in `load'
	from /usr/share/gems/gems/thin-1.3.1/lib/thin/controllers/controller.rb:181:in `load_rackup_config'
	from /usr/share/gems/gems/thin-1.3.1/lib/thin/controllers/controller.rb:71:in `start'
	from /usr/share/gems/gems/thin-1.3.1/lib/thin/runner.rb:185:in `run_command'
	from /usr/share/gems/gems/thin-1.3.1/lib/thin/runner.rb:151:in `run!'
	from /usr/share/deltacloud-core/bin/deltacloudd:239:in `<top (required)>'
	from /usr/bin/deltacloudd:5:in `load'
	from /usr/bin/deltacloudd:5:in `<main>'

So I commented out this in driver_helper.rb 

#        require_relative(driver_source_name) unless driver_class

(I also tried full path in the File.Join with same result below)

which seemed to allow the file to at least be read, but then I encountered another error:

# deltacloudd -i openstack
Starting Deltacloud API :: openstack :: http://127.0.0.1:35357/v2.0/ :: http://localhost:3001/api

/usr/share/deltacloud-core/lib/deltacloud/collections/images.rb:21:in `block in <class:Images>': undefined method `has_feature?' for NilClass:Class (NoMethodError)
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:334:in `call'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:334:in `block in generate'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:332:in `each'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:332:in `generate'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:231:in `operation'
	from /usr/share/deltacloud-core/lib/deltacloud/collections/images.rb:32:in `block in <class:Images>'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:106:in `class_eval'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base.rb:106:in `generate'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/dsl.rb:36:in `block in collection'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base_collection.rb:56:in `rescue in collection_class'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/base_collection.rb:53:in `collection_class'
	from /usr/share/gems/gems/sinatra-rabbit-1.0.9/lib/sinatra/rabbit/dsl.rb:34:in `collection'
	from /usr/share/deltacloud-core/lib/deltacloud/collections/images.rb:29:in `<class:Images>'
	from /usr/share/deltacloud-core/lib/deltacloud/collections/images.rb:17:in `<module:Collections>'
	from /usr/share/deltacloud-core/lib/deltacloud/collections/images.rb:16:in `<top (required)>'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/deltacloud-core/lib/deltacloud/collections.rb:38:in `block in <module:Collections>'
	from /usr/share/deltacloud-core/lib/deltacloud/collections.rb:37:in `each'
	from /usr/share/deltacloud-core/lib/deltacloud/collections.rb:37:in `<module:Collections>'
	from /usr/share/deltacloud-core/lib/deltacloud/collections.rb:27:in `<module:Deltacloud>'
	from /usr/share/deltacloud-core/lib/deltacloud/collections.rb:17:in `<top (required)>'
	from /usr/share/deltacloud-core/lib/deltacloud/server.rb:28:in `require_relative'
	from /usr/share/deltacloud-core/lib/deltacloud/server.rb:28:in `<top (required)>'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/deltacloud-core/lib/deltacloud_rack.rb:44:in `require_frontend!'
	from /usr/share/deltacloud-core/config.ru:61:in `block in <main>'
	from /usr/share/gems/gems/rack-1.4.0/lib/rack/builder.rb:51:in `instance_eval'
	from /usr/share/gems/gems/rack-1.4.0/lib/rack/builder.rb:51:in `initialize'
	from /usr/share/deltacloud-core/config.ru:1:in `new'
	from /usr/share/deltacloud-core/config.ru:1:in `<main>'
	from /usr/share/gems/gems/thin-1.3.1/lib/rack/adapter/loader.rb:36:in `eval'
	from /usr/share/gems/gems/thin-1.3.1/lib/rack/adapter/loader.rb:36:in `load'
	from /usr/share/gems/gems/thin-1.3.1/lib/thin/controllers/controller.rb:181:in `load_rackup_config'
	from /usr/share/gems/gems/thin-1.3.1/lib/thin/controllers/controller.rb:71:in `start'
	from /usr/share/gems/gems/thin-1.3.1/lib/thin/runner.rb:185:in `run_command'
	from /usr/share/gems/gems/thin-1.3.1/lib/thin/runner.rb:151:in `run!'
	from /usr/share/deltacloud-core/bin/deltacloudd:239:in `<top (required)>'
	from /usr/bin/deltacloudd:5:in `load'
	from /usr/bin/deltacloudd:5:in `<main>'


# rpm -qa | grep delta
condor-deltacloud-gahp-7.7.5-0.2.fc17.2.x86_64
deltacloud-core-ec2-1.0.0-8.fc17.noarch
libdeltacloud-0.9-2.fc17.x86_64
deltarpm-3.6-0.7.20110223git.fc17.x86_64
deltacloud-core-vsphere-1.0.0-8.fc17.noarch
python-deltarpm-3.6-0.7.20110223git.fc17.x86_64
libdeltacloud-devel-0.9-2.fc17.x86_64
deltacloud-core-openstack-1.0.0-8.fc17.noarch
xdelta-3.0.0-3.fc17.x86_64
rubygem-deltacloud-client-0.5.0-3.fc17.noarch
deltacloud-core-rhevm-1.0.0-8.fc17.noarch
deltacloud-core-1.0.0-8.fc17.noarch
deltacloud-core-rackspace-1.0.0-8.fc17.noarch
Comment 1 Michal Fojtik 2012-09-13 05:17:33 EDT
Hi Jon,

This is caused because of missing 'rubygem-openstack' gem. This gem is currently being packaged for Fedora and we will update deltacloud-core-openstack RPM right after this gem will be pushed to Fedora.
Comment 2 Jon Thomas 2012-09-21 09:45:22 EDT
Installed rubygem-openstack.noarch 0:1.0.6-1.fc17 and deltacloud-core-openstack.noarch 0:1.0.3-1.fc17 and things seem to be fixed


# deltacloudd -i openstack
Starting Deltacloud API :: openstack :: http://localhost:3001/api

>> Thin web server (v1.3.1 codename Triple Espresso)
>> Debugging ON
>> Maximum connections set to 1024
>> Listening on localhost:3001, CTRL+C to stop
^C>> Stopping ...
Comment 3 Fedora End Of Life 2013-07-03 20:49:44 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2013-08-01 00:57:17 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.