Bug 856365 - [abrt] galternatives-0.13.4-11.fc17: alternative.py:90:__init__:OSError: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/etc/alternatives/javaws'
[abrt] galternatives-0.13.4-11.fc17: alternative.py:90:__init__:OSError: [Err...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: galternatives (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
abrt_hash:0f7488ba88fc1899ada8a5f8b1c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 17:52 EDT by Henning
Modified: 2012-09-20 18:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 18:14:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (367 bytes, text/plain)
2012-09-11 17:52 EDT, Henning
no flags Details

  None (edit)
Description Henning 2012-09-11 17:52:17 EDT
Version-Release number of selected component:
galternatives-0.13.4-11.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
cmdline:        /usr/bin/python /usr/sbin/galternatives
kernel:         3.5.2-3.fc17.x86_64

backtrace:
:alternative.py:90:__init__:OSError: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/etc/alternatives/javaws'
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/galternatives/main.py", line 371, in alternative_selected_cb
:    self.update_metainfo ()
:  File "/usr/lib/python2.7/site-packages/galternatives/main.py", line 466, in update_metainfo
:    self.alternative = Alternative (tm.get_value (iter, self.ALTERNATIVES))
:  File "/usr/lib/python2.7/site-packages/galternatives/alternative.py", line 90, in __init__
:    (unixname))
:OSError: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/etc/alternatives/javaws'
:
:Local variables in innermost frame:
:altfile: <open file '/var/lib/alternatives/javaws', mode 'r' at 0x261b270>
:locale: 'C'
:line: ''
:unixname: 'javaws'
:self: <galternatives.alternative.Alternative instance at 0x2743d88>
Comment 1 Henning 2012-09-11 17:52:20 EDT
Created attachment 611947 [details]
File: core_backtrace
Comment 2 Henning 2012-09-12 01:39:41 EDT
Hello,
sorry - I forgot to mention how this error happened and how to reproduce (afterall I cannot reproduce anymore).

I followed steps mentioned here:
http://www.if-not-true-then-false.com/2010/install-sun-oracle-java-jdk-jre-6-on-fedora-centos-red-hat-rhel/

to implement current Oracle JDK 1.7

During step;
# alternatives --install /usr/bin/javaws javaws /usr/java/jdk1.7.0_07/jre/bin/javaws 20000
it failed, as there was missing link /usr/bin/javaws
(all other went fine: java, javac, ,...)

So I thought I check it via the visual tool "galternatives", but it hung.
I think this caused the error.

Then I finally fixed it by using alternatives directly (I forgot again what I did to fix it). 

Afterwards "galternatives" was fine as well (no  errors anymore)

Thank you and regards,
Henning
Comment 3 Deji Akingunola 2012-09-20 18:14:07 EDT
I'm glad you were able to resolve this issue. I'm going to go ahead and close the bug. Thanks.

Note You need to log in before you can comment on or make changes to this bug.