Bug 856375 - Reduce volume of email notifications sent to ecs_notify group
Reduce volume of email notifications sent to ecs_notify group
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Email Notifications (Show other bugs)
4.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Matt Tyson
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 18:41 EDT by Douglas Silas
Modified: 2013-06-23 23:21 EDT (History)
6 users (show)

See Also:
Fixed In Version: 4.2.4-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 22:54:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Silas 2012-09-11 18:41:16 EDT
Description of problem: the volume of mail that Bugzilla generates and sends to members of the ecs_notify group is too high to be sustainable. Need to reduce number of auto-generated emails.


Version-Release number of selected component (if applicable): version 4.2.3-4.1


How reproducible: join the ecs_notify group and witness that you get notified about all changes to the Doc Type field across all products.

Expected results: this bug seeks to reduce the number of notifications. A future RFE may request more fine-grained permissions for ecs_notify notifications.

We are requesting that Bugzilla not send email notifications to ecs_notify group members when:

* due to keyword analysis alone, Doc Type is changed. This is available in the bug history in case it is needed, so we can dispense with it. All other instances in which a notification is sent should be retained. (I believe that all of these instances also involve Doc Text being changed simultaneously, but am not absolutely positive about that.)

* (a) the product is not in the "Red Hat" or "JBoss" classifications, (b) unless someone has manually requested that a product in one of the other classifications--Fedora, Internal, Community, Other--should receive notifications. Note that if (b) is difficult to implement, then implementing (a) should be sufficient. The documentation will be changed to reflect that notifications (a) aren't send to the non-RH, non-JBoss products by designed default, and, possibly, (b) that they must be explicitly requested.

Additional info: none at present. Thanks.
Comment 1 Simon Green 2012-09-11 19:07:00 EDT
Having spoken on irc this morning, and this is the updated requirement

We are requesting that Bugzilla send email notifications to ecs_notify group members only when:

* the 'Doc Text' field is changed, and
* the bug is in the "Red Hat" or "JBoss" classifications

Note You need to log in before you can comment on or make changes to this bug.