Bug 856499 - Test case failure: Permission inheritance for desktop pools
Test case failure: Permission inheritance for desktop pools
Status: CLOSED DUPLICATE of bug 839490
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.1.0
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Oved Ourfali
Pavel Stehlik
virt infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 03:18 EDT by Ondra Machacek
Modified: 2015-09-09 06:31 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
In environments that contain virtual machine pools it is recommended that you do not assign user roles other than VM_CREATOR, TEMPLATE_CREATOR, and DISK_CREATOR at the system, data center, or cluster level. Assigning user roles other than these, at the specified levels is known to cause unexpected behaviour related to virtual machine pools in the User Portal. The ability to assign administrative roles at the system, data center and cluster level is unaffected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-13 08:25:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (15.26 KB, text/x-log)
2012-09-12 05:14 EDT, Ondra Machacek
no flags Details

  None (edit)
Description Ondra Machacek 2012-09-12 03:18:37 EDT
Filed from caserun (https://tcms.engineering.redhat.com/run/45425/?from_plan=2602#caserun_1488123)

Version-Release number of selected component (if applicable):
si16.2

Steps to Reproduce: 
Data-center with UserRole permission, template for desktop pool creation.


 1. Check that data-center has a user with UserRole permission
 2. Create new desktop pool
 3. Check that permission was inherited from data-center
 4. Go to User-portal and ensure that user can take a machine from created
    pool.



Actual results: 
In user portal user can't run VM taken from VMpool. Stop and shutdown actions works fine.

Expected results:
  * New created desktop pool has inherited permissions from data-center
  * User is able to run and take VM from the pool via User portal
Comment 2 Ondra Machacek 2012-09-12 05:14:45 EDT
Created attachment 612038 [details]
engine.log
Comment 3 Einav Cohen 2012-09-13 08:25:12 EDT
the actual problem is that you see pool-VMs that you shouldn't see (see bug 839490, comment #13 for more details).
there are situations in which you are supposed to be able to run VMs from pool (e.g. if you have a VM from a manual pool, for example), however - this works OK (verified).

Closing as duplicate.
Comment 4 Einav Cohen 2012-09-13 08:25:43 EDT

*** This bug has been marked as a duplicate of bug 839490 ***

Note You need to log in before you can comment on or make changes to this bug.