Bug 856586 - After creating new file using Satellite API which ends with new lines "\n" these empty lines are lost.
After creating new file using Satellite API which ends with new lines "\n" th...
Status: CLOSED DUPLICATE of bug 595500
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
541
All All
unspecified Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: 819027
  Show dependency treegraph
 
Reported: 2012-09-12 07:16 EDT by Petr Ruzicka
Modified: 2013-03-07 19:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-26 08:00:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer (793 bytes, application/x-perl)
2012-09-12 07:17 EDT, Petr Ruzicka
no flags Details

  None (edit)
Description Petr Ruzicka 2012-09-12 07:16:29 EDT
*** Description of problem:
When I'm trying to create the new config file using API which looks like: "Test\n\n\n\n" - then the last 4 x \n are lost.

*** Version-Release number of selected component (if applicable):
RHNS 5.4.1

*** How reproducible:
See the attached script.

*** Steps to Reproduce:
1. See the attached script.
  
*** Actual results:
The empty new lines are lost from the config files.

*** Expected results:
The empty lines should be preserved (they should not be changed).

*** Additional info:
Comment 1 Petr Ruzicka 2012-09-12 07:17:17 EDT
Created attachment 612067 [details]
Reproducer
Comment 2 Tomas Lestach 2012-09-26 08:00:27 EDT
You have to base64 encode the content, if you want to preserve whitespace.

*** This bug has been marked as a duplicate of bug 595500 ***

Note You need to log in before you can comment on or make changes to this bug.