Bug 856608 - rhncfg-manager diff fails - missing dependency spacewalk-backend-libs
rhncfg-manager diff fails - missing dependency spacewalk-backend-libs
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client (Show other bugs)
550
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Stephen Herr
Lukas Pramuk
: Regression
Depends On:
Blocks: 819027
  Show dependency treegraph
 
Reported: 2012-09-12 08:15 EDT by Martin Minar
Modified: 2016-07-03 20:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhncfg-5.10.27-12-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-12 05:07:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Minar 2012-09-12 08:15:52 EDT
Description of problem:


Version-Release number of selected component (if applicable):
rhncfg-management-5.10.27-7.el6sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. yum install rhncfg-management (rhncfg will be installed as dependency)
2. rhncfg-manager diff --help
  
Actual results:
Unable to load plugin for mode 'diff': No module named spacewalk.common.fileutils

Expected results:
Help shown

Additional info:
Problem is that rhncfg-management doesn't have spacewalk-backend-libs as dependency.
It's an regression against rhncfg-management-5.9.27-17 (RHN-Tools from 5.4.1) where rhncfg-manager diff worked without spacewalk-backend-libs.
Comment 2 Stephen Herr 2013-01-30 11:29:37 EST
Committed to Spacewalk master: bec08806ac9fb3a7e03c8947769af382d9860195
Comment 7 errata-xmlrpc 2013-02-12 05:07:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0252.html

Note You need to log in before you can comment on or make changes to this bug.