Bug 856617 - Unable to get list of components via XML-RPC
Unable to get list of components via XML-RPC
Status: CLOSED NEXTRELEASE
Product: Bugzilla
Classification: Community
Component: WebService (Show other bugs)
4.2
All Linux
urgent Severity urgent (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
tools-bugs
: Regression, Reopened
Depends On: 817459
Blocks: 508685
  Show dependency treegraph
 
Reported: 2012-09-12 08:44 EDT by David Kovalsky
Modified: 2014-03-31 19:46 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 19:59:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2012-09-12 08:44:30 EDT
I'm trying to get a list of components via XML-RPC for RHEL7 ("Red Hat Enterprise LInux 7" product) same as I'm doing for RHEL3,4,5,6 - but it's not working. On ticket it has been suggested this is a bug and I should file one here. 

I have this Python
con = xmlrpclib.ServerProxy(self.url)
con.User.login({"login" : self.login, "password": self.passwd})
product = con.Product.get({"names" : self.bz_product})


for RHEL4,5,6 product is an array (list) of product info and
components, for RHEL7 `product' is an empty list (`[]').

I'm pretty certain this used to work a couple of weeks ago, though through Python-bugzilla package.


This is blocking CYP functionality, deployment of new version, addition of any new components. And since tools like automated Beaker QE workflows rely on CYP same as Errata Tool does, it's top priority for me to get this bug fixed.



Red Hat Bugzilla 4.2.3-4.1
Comment 5 HSS Product Manager 2012-09-26 18:47:04 EDT
Product Management has reviewed and declined this request. You may appeal this
decision by reopening this request.
Comment 9 Matt Tyson 2012-11-01 19:59:45 EDT
I've tested this against release 4.2-6 of bugzilla which will be released shortly and everything works as expected.  Components for RHEL 7 are returned.
Comment 10 xuezhi ma 2012-11-19 22:28:05 EST
Verify version: 4.2-6 on production and 4.2-7 test server -> PASS

Verify steps:
>>> import xmlrpclib
>>> proxy = xmlrpclib.ServerProxy('xmprpc URL')
>>> cops = proxy.Product.get({'Bugzilla_login': 'user@redhat.com', 'Bugzilla_password': 'PWD', 'names':['Red Hat Enterprise Linux 7']})
>>> for i in range(0, len(cops['products'][0]['components'])):
>>>    print '---------------------------------------'
>>>    print cops['products'][0]['components'][i]


Actual result:
User can get components of RHEL7

Note You need to log in before you can comment on or make changes to this bug.