Bug 856621 - f18a rc2 anaconda automatic partitioning fails to remove previous lvm pv and installation process stalls at "preparing to install'
f18a rc2 anaconda automatic partitioning fails to remove previous lvm pv and ...
Status: CLOSED DUPLICATE of bug 853977
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 08:54 EDT by Reartes Guillermo
Modified: 2012-09-12 10:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-12 10:17:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage log (102.27 KB, text/x-log)
2012-09-12 08:54 EDT, Reartes Guillermo
no flags Details
program log (26.06 KB, text/x-log)
2012-09-12 08:55 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-09-12 08:54:16 EDT
Created attachment 612089 [details]
storage log

Description of problem:

A previous lvm stuff is on disk and anaconda is unable to start the
installation process when using automatic partitioning because it seems
to not to be able to remove the existing lmv pv.

Version-Release number of selected component (if applicable):
f18a rc2 dvd

How reproducible:
always

Steps to Reproduce:
1. boot in graphical
2. fill all anacona requeriments and do an automatic partitioning
3. anaconda stalls at 'preparing to install'
  
Actual results:
no install

Expected results:
install

Additional info:
see attached logs.
Comment 1 Reartes Guillermo 2012-09-12 08:55:02 EDT
Created attachment 612090 [details]
program log

09:26:05,373 INFO program: Running... udevadm settle --timeout=300
09:26:05,647 INFO program: Running... lvm pvremove --force --force --config  devices { filter=["r|/loop3$|","r|/loop4$|","r|/loop5$|","r|/loop6$|","r|/loop7$|","r|/fedora-root$|","r|/fedora$|","r|/sdb1$|","r|/sdb$|"] }  /dev/sda1
09:26:06,041 ERR program:   Couldn't find device with uuid LQNJGd-eAil-p1cB-PU83-ysJL-qjDG-xhFAHD.
(END)
Comment 2 Chris Lumens 2012-09-12 10:17:32 EDT
I think this is fixed by 853977, given that we are hung up on a pvremove and the patch from that bug adds arguments to pvremove.

Unfortunately, that's a private bug.  However the important thing to note is that it's in modified and anaconda-18.8 should be tne build on master that'll have the fix.  So, post-alpha.

*** This bug has been marked as a duplicate of bug 853977 ***

Note You need to log in before you can comment on or make changes to this bug.