Bug 856641 - Unchecking "Enable WAN Options" in UP has no effect
Unchecking "Enable WAN Options" in UP has no effect
Status: CLOSED DUPLICATE of bug 913183
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.1.0
Unspecified Windows
unspecified Severity low
: ---
: ---
Assigned To: Tomas Jelinek
Oded Ramraz
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 09:50 EDT by Milan Barta
Modified: 2015-10-27 20:19 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 08:24:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Barta 2012-09-12 09:50:58 EDT
Description of problem:
After unchecking the "Enable WAN Options" option in User Portal and connecting to the VM using remote-viewer on Windows client, the effects like bit depth, animations, etc. are not disabled.
The only way to reenable the effects is to restart the browser the User Portal is opened in and connecting to the VM again.

Version-Release number of selected component (if applicable):
RHEVM 3.1.0-14.el6ev
mingw-virt-viewer-0.5.3-11.el6

Tested on: Windows 7 64-bit (both client and guest)

How reproducible:
Always

Steps to Reproduce:
1. Edit console options in UP -> check the "Enable WAN Options"
2. Connect to Windows VM using the remote-viewer (effects are disabled)
3. Disconnect from the VM and uncheck the "Enable WAN Options"
4. Connect to the VM again
  
Actual results:
Unchecking the option has no effect.
Effects stay disabled.

Expected results:
The effects are reenabled without the need to restart the browser.

Additional info:
Comment 1 Michal Skrivanek 2012-09-25 03:59:20 EDT
tomas will investigate, but may not be worth fixing in 3.1....
Comment 2 David Jaša 2012-11-09 08:49:06 EST
the spicex debug log (at %temp%\spicex.log with SPICEX_DEBUG_LEVEL environment variable set to 0) suggests that the problem is that User Portal does not reset/unset the related variables on the spice-x object:


1. WAN options in default state after browser launch, msg id 20 and 21 are not sent (colour bit depth and disable effects: http://cgit.freedesktop.org/spice/spice-protocol/tree/spice/controller_prot.h#n78): 

1352466785 DEBUG [2672:1180] COSpiceX::put_DynamicMenu: DynamicMenu
1352466785 INFO [2672:1180] COSpiceX::put_FullScreen: New FullScreen request newVal=0x0
1352466785 DEBUG [2672:1180] COSpiceX::Connect: Running spicec (C:\Users\1\AppData\Local\virt-viewer\bin\remote-viewer.exe --spice-controller)
1352466785 INFO [2672:1180] COSpiceX::Connect: spicec pid 2536
1352466785 DEBUG [2672:1180] COSpiceX::Connect: connecting to spice client's pipe
1352466786 DEBUG [2672:1180] COSpiceX::send_init: sending init
1352466786 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 1 : str 10.34.58.5 (1)
1352466786 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 2 value 5904
1352466786 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 3 value 5905
1352466786 DEBUG [2672:1180] COSpiceX::send_wstr: sending password
1352466786 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 11 : str win7x64-dj:%d - Press SHIFT+F12 to Release Cursor (1)
1352466786 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 14 : str release-cursor=shift+f12,toggle-fullscreen=shift+f11 (1)
1352466786 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 5 : str main,inputs,cursor,playback,record,display,usbredir,smartcard (1)
1352466786 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 7 : str DEFAULT (1)
1352466786 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 9 : str O=spice.lab.eng.brq.redhat.com,CN=10.34.58.5 (1)
1352466786 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 8 : str C:\Users\1\AppData\Local\Temp\truststore.pem (1)
1352466786 DEBUG [2672:1180] COSpiceX::send_msg: sending msg id 16
1352466786 DEBUG [2672:1180] COSpiceX::send_msg: sending msg id 17
1352466786 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 22 value 1
1352466786 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 23 value 1
1352466786 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 24 : str -1,60186,10000,256,1|-1,1118,245,-1,1|-1,1133,2245,-1,1|-1,1133,2242,5,1|8,-1,-1,-1,1|7,-1,-1,-1,1|-1,-1,-1,-1,1
 (0)
1352466875 INFO [2672:2628] COSpiceX::event_thread: exit_code=0 error_code=1



2. WAN options are set, msg ids 20 and 21 are set to 16 and animation respectively:

1352466894 DEBUG [2672:1180] COSpiceX::put_DynamicMenu: DynamicMenu
1352466894 INFO [2672:1180] COSpiceX::put_FullScreen: New FullScreen request newVal=0x0
1352466894 DEBUG [2672:1180] COSpiceX::Connect: Running spicec (C:\Users\1\AppData\Local\virt-viewer\bin\remote-viewer.exe --spice-controller)
1352466894 INFO [2672:1180] COSpiceX::Connect: spicec pid 488
1352466894 DEBUG [2672:1180] COSpiceX::Connect: connecting to spice client's pipe
1352466895 DEBUG [2672:1180] COSpiceX::send_init: sending init
1352466895 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 1 : str 10.34.58.5 (1)
1352466895 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 2 value 5904
1352466895 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 3 value 5905
1352466895 DEBUG [2672:1180] COSpiceX::send_wstr: sending password
1352466895 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 11 : str win7x64-dj:%d - Press SHIFT+F12 to Release Cursor (1)
1352466895 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 14 : str release-cursor=shift+f12,toggle-fullscreen=shift+f11 (1)
1352466895 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 5 : str main,inputs,cursor,playback,record,display,usbredir,smartcard (1)
1352466895 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 7 : str DEFAULT (1)
1352466895 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 9 : str O=spice.lab.eng.brq.redhat.com,CN=10.34.58.5 (1)
1352466895 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 8 : str C:\Users\1\AppData\Local\Temp\truststore.pem (1)
1352466895 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 20 value 16
1352466895 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 21 : str animation (1)
1352466895 DEBUG [2672:1180] COSpiceX::send_msg: sending msg id 16
1352466895 DEBUG [2672:1180] COSpiceX::send_msg: sending msg id 17
1352466895 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 22 value 1
1352466895 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 23 value 1
1352466895 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 24 : str -1,60186,10000,256,1|-1,1118,245,-1,1|-1,1133,2245,-1,1|-1,1133,2242,5,1|8,-1,-1,-1,1|7,-1,-1,-1,1|-1,-1,-1,-1,1
 (0)
1352467624 INFO [2672:2316] COSpiceX::event_thread: exit_code=0 error_code=1



3. "Enable WAN options" checkbox is unchecked but msg ids 20 and 21 are still used (aka respective variables on the spice-x element were not reset to their original value):

1352467633 DEBUG [2672:1180] COSpiceX::put_DynamicMenu: DynamicMenu
1352467633 INFO [2672:1180] COSpiceX::put_FullScreen: New FullScreen request newVal=0x0
1352467633 DEBUG [2672:1180] COSpiceX::Connect: Running spicec (C:\Users\1\AppData\Local\virt-viewer\bin\remote-viewer.exe --spice-controller)
1352467633 INFO [2672:1180] COSpiceX::Connect: spicec pid 1220
1352467633 DEBUG [2672:1180] COSpiceX::Connect: connecting to spice client's pipe
1352467634 DEBUG [2672:1180] COSpiceX::send_init: sending init
1352467634 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 1 : str 10.34.58.5 (1)
1352467634 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 2 value 5904
1352467634 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 3 value 5905
1352467634 DEBUG [2672:1180] COSpiceX::send_wstr: sending password
1352467634 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 11 : str win7x64-dj:%d - Press SHIFT+F12 to Release Cursor (1)
1352467634 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 14 : str release-cursor=shift+f12,toggle-fullscreen=shift+f11 (1)
1352467634 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 5 : str main,inputs,cursor,playback,record,display,usbredir,smartcard (1)
1352467634 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 7 : str DEFAULT (1)
1352467634 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 9 : str O=spice.lab.eng.brq.redhat.com,CN=10.34.58.5 (1)
1352467634 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 8 : str C:\Users\1\AppData\Local\Temp\truststore.pem (1)
1352467634 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 20 value 16
1352467634 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 21 : str animation (1)
1352467634 DEBUG [2672:1180] COSpiceX::send_msg: sending msg id 16
1352467634 DEBUG [2672:1180] COSpiceX::send_msg: sending msg id 17
1352467634 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 22 value 1
1352467634 DEBUG [2672:1180] COSpiceX::send_value: sending msg id 23 value 1
1352467634 DEBUG [2672:1180] COSpiceX::send_wstr: sending msg id 24 : str -1,60186,10000,256,1|-1,1118,245,-1,1|-1,1133,2245,-1,1|-1,1133,2242,5,1|8,-1,-1,-1,1|7,-1,-1,-1,1|-1,-1,-1,-1,1
 (0)
Comment 3 David Jaša 2012-11-09 09:10:43 EST
If I read the test page code correctly, you should just set ColorDepth and DisableEffect variables of the spicex <object> to an empty string.
Comment 6 Tomas Jelinek 2013-07-17 08:24:58 EDT

*** This bug has been marked as a duplicate of bug 913183 ***

Note You need to log in before you can comment on or make changes to this bug.