Bug 85667 - multipart/form-data does not work
multipart/form-data does not work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-05 13:55 EST by Gerald Teschl
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-01 10:27:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2003-03-05 13:55:16 EST
Description of problem:
I tried to install squirelmail, but one cannot send emails. I traced the
problem down to the fact that a form using 'multipart/form-data' will
behave like nothing is submitted.

Version-Release number of selected component (if applicable):
php-4.1.2-7.3.6
apache-1.3.27-2

How reproducible:
100%

Steps to Reproduce:
Call the following script
---------------------------------------------
<form action="action.php" method="POST"  ENCTYPE="multipart/form-data">
 Your name: <input type="text" name="name" />
 <input type="submit" name=test>
</form>
<hr>
<?php if (isset($_POST['test'])) { ?>
Hi <?php echo $_POST["name"]; ?>.
<?php } ?>
---------------------------------------------
Enter "xxx" and submit the date.

    
Actual results:
No "Hi xxx." is printed.

Expected results:
"Hi xxx." should be printed.

Additional info:
1) This is not a client problem. I tried different clients.
2) If one removes 'ENCTYPE="multipart/form-data"' it will work.
3) On RH 8.0 the same script works.
Comment 1 Joe Orton 2003-04-07 09:36:24 EDT
You say this *works* in 8.0, yet you have filed this bug against 8.0? Did you
mean to file this against a 7.x release?
Comment 2 Gerald Teschl 2003-04-07 14:10:57 EDT
Sorry, you are right, I wanted to file this against 7.3

Note You need to log in before you can comment on or make changes to this bug.