Bug 856670 - Aeolus-cleanup error:Must pass nfs_mount_point to Aeolus::Profiles::Rhevm::Disable[default] at /usr/share/aeolus-configure/modules/aeolus/manifests/profiles/rhevm/disable.pp:
Aeolus-cleanup error:Must pass nfs_mount_point to Aeolus::Profiles::Rhevm::Di...
Status: CLOSED WONTFIX
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Mo Morsi
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 10:35 EDT by Aziza Karol
Modified: 2013-08-14 15:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 15:04:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
morazi: needinfo+


Attachments (Terms of Use)

  None (edit)
Description Aziza Karol 2012-09-12 10:35:06 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Install aeolus and  run aeolus-configure.
2.Try aeolus-cleanup.

For rhevm-clean up i get:
#aeolus-cleanup -p rhevm
aeolus-cleanup will delete local aeolus installations.
Are you sure you wish to proceed? [y/N]: y
Must pass nfs_mount_point to Aeolus::Profiles::Rhevm::Disable[default] at /usr/share/aeolus-configure/modules/aeolus/manifests/profiles/rhevm/disable.pp:15 on node dell-pe1950-1.rhts.eng.rdu.redhat.com

#aeolus-cleanup -p vsphere,ec2,mock
aeolus-cleanup will delete local aeolus installations.
Are you sure you wish to proceed? [y/N]: y
File not found: /etc/aeolus-configure/nodes/vsphere_cleanup


Expected results:


Additional info:
rpm -qa | grep aeolus
aeolus-all-0.13.0-0.20120911080010git2f1db53.fc16.noarch
rubygem-aeolus-image-0.6.0-0.20120912040016git902c81c.fc16.noarch
aeolus-conductor-0.13.0-0.20120911080010git2f1db53.fc16.noarch
rubygem-aeolus-cli-0.7.0-0.20120912040013git8a46b3f.fc16.noarch
aeolus-conductor-doc-0.13.0-0.20120911080010git2f1db53.fc16.noarch
aeolus-conductor-daemons-0.13.0-0.20120911080010git2f1db53.fc16.noarch
aeolus-configure-2.8.0-0.20120912040010git0b3dad6.fc16.noarch
Comment 2 Mike Orazi 2012-09-12 17:02:32 EDT
This appears to be 2 issues:

1.  The first issue looks like you didn't edit /etc/aeolus-configure/nodes/rhevm_cleanup to telli t about nfs_mount_point (there is a section in there that needs to be uncommented out prior to running aeolus-cleanup)

2.  vsphere, ec2, mock don't have corresponding *_cleanup descriptions.  We limit cleanup pretty severely so we don't accidentally remove provider/provider account info.  rhevm has a cleanup to remove the nfs mount, but none of the other providers require a similar setup.  I'm not sure we want to dig too much deeper into removal of resources than that.

Thoughts?
Comment 3 Mike Orazi 2012-09-12 17:04:18 EDT
To be more explicit, if you go along with the explanation in 2 and agree, please CLOSE as not a bug.  If I'm missing something or there is disagreement on point 2, let's discuss.
Comment 4 Mo Morsi 2013-01-28 15:41:08 EST
Pushed a patch addressing #1 so that the nfs unmount will be skipped over if mount point is not specified

https://github.com/aeolusproject/aeolus-configure/commit/601ee822a6559ba76abe9ad02e6cb5a2bc449609


And yes, as far as #2 that is the intended behaviour. We have a check that gets run as part of configure and cleanup that ensures the specified profile exists and outputs a "File not found" before exiting if it doesn't.
Comment 5 Mo Morsi 2013-08-14 15:04:56 EDT
aeolus is no longer being developed

Note You need to log in before you can comment on or make changes to this bug.