Bug 856710 - 3.1 - host losses connectivity when moving rhevm network from one interface to another (rollback doesn't work)
3.1 - host losses connectivity when moving rhevm network from one interface t...
Status: CLOSED DUPLICATE of bug 857112
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
Unspecified Unspecified
high Severity urgent
: rc
: ---
Assigned To: Igor Lvovsky
GenadiC
network
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 11:55 EDT by Ondra Machacek
Modified: 2012-09-23 10:48 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-23 10:48:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log (2.73 MB, text/x-log)
2012-09-14 03:55 EDT, Ondra Machacek
no flags Details

  None (edit)
Description Ondra Machacek 2012-09-12 11:55:33 EDT
Description of problem:


Version-Release number of selected component (if applicable):
vdsm-4.9.6-31.0.el6_3

How reproducible:
always

Steps to Reproduce:
1. Have rhevm on em1(up) and have rhevm bridge on it. And have em2(no_carrier) and without rhevm bridge on it.
2. Try to assign rhevm bridge from em1 to em2. Have 'Verify connectivity between Host and Engine' checked and 'Save network configuration' checked. Click OK.
  
Actual results:
rhevm <=> vdsm connection breaks.

Expected results:
Error message: this action should destroy connection, do rollback.

Additional info:
Comment 2 Jaroslav Henner 2012-09-12 12:09:25 EDT
Expected results should be:
Error message: this action would destroy connection, doing roll-back.
Comment 3 Dan Kenigsberg 2012-09-13 15:35:57 EDT
please attach relevant vdsm.log. I would very much request a reproduction with vdsm-4.9.6-34.0 that has better logging.
Comment 4 Ondra Machacek 2012-09-14 03:55:01 EDT
Created attachment 612770 [details]
vdsm.log
Comment 5 GenadiC 2012-09-23 08:01:54 EDT
From the tests we performed on SI18 it looks like the problem happens only for DHCP (rollback on static IP for rhevm network worked fine).
As well the problem is not seen anymore (even on DHCP configuration) after testing http://gerrit.ovirt.org/#/c/8058/ that fixes the https://bugzilla.redhat.com/show_bug.cgi?id=857112
We'll need to verify it in the next release when that fix will be merged.
Comment 6 Dan Kenigsberg 2012-09-23 10:48:51 EDT
Apparently, the same underlying problem - infecting all ifcfg* files with BOOTPROTO - caused this bug. Therefore, I'm closing it as a duplicate. Please re-open if I am mistaken.

*** This bug has been marked as a duplicate of bug 857112 ***

Note You need to log in before you can comment on or make changes to this bug.