Bug 856725 - doxygen-1.8.0 requires a newer python 2.4 to rebuild devtoolset-1.0-gcc
doxygen-1.8.0 requires a newer python 2.4 to rebuild devtoolset-1.0-gcc
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: gcc (Show other bugs)
DTS 1.0 RHEL 5
x86_64 Linux
unspecified Severity low
: beta1
: 1.1
Assigned To: Jakub Jelinek
Martin Cermak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 12:13 EDT by Tru Huynh
Modified: 2013-01-22 09:35 EST (History)
6 users (show)

See Also:
Fixed In Version: devtoolset-1.1-gcc-4.7.1-8.el5
Doc Type: Release Note
Doc Text:
Previously, the doxygen utility required a newer version of the Python interpreter. This has been fixed with the Red Hat Developer Toolset 1.1 Beta-1 release so that doxygen now works with Python 2.4.3, as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-22 09:35:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
doxygen patch (571 bytes, patch)
2012-09-12 12:16 EDT, Tru Huynh
no flags Details | Diff

  None (edit)
Description Tru Huynh 2012-09-12 12:13:11 EDT
Description of problem:
rpmbuild \
--define 'scl devtoolset-1.0' \
--target=x86_64 -ba --rmsource --rmspec --clean devtoolset-1.0-gcc.spec
fails

Version-Release number of selected component (if applicable):
devtoolset-1.0-gcc-4.7.0-5.2.el5.src.rpm
devtoolset-1.0-gcc-4.7.0-5.3.el5.src.rpm
python-2.4.3-46.el5_8.2.x86_64

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
gmake[2]: Entering directory `/home/centos/rpm/BUILD/gcc-4.7.0-20120507/doxygen-1.8.0/src'
/usr/bin/flex -PconfigYY -t config.l >config.cpp
python configgen.py config.xml >configoptions.cpp
g++ -c -pipe -D_LARGEFILE_SOURCE -Wall -W -fno-exceptions -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -I../qtools -o ../objects/portable.o portable.cpp
gcc -c -pipe -Wall -W -fno-exceptions -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -I../qtools -o ../objects/portable_c.o portable_c.c
portable_c.c: In function 'portable_iconv':
portable_c.c:17: warning: passing argument 2 of 'iconv' from incompatible pointer type
g++ -c -pipe -D_LARGEFILE_SOURCE -Wall -W -fno-exceptions -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -I../qtools -o ../objects/config.o config.cpp
config.l: In function 'int configYYlex()':
config.l:805: warning: ignoring return value of 'size_t fwrite(const void*, size_t, size_t, FILE*)', declared with attribute warn_unused_result
  File "configgen.py", line 38
    enabled = "TRUE" if defval=='1' else "FALSE"
                      ^
SyntaxError: invalid syntax
gmake[2]: *** [configoptions.cpp] Error 1
gmake[2]: *** Waiting for unfinished jobs....


Expected results:
no errors

Additional info:
Comment 1 Tru Huynh 2012-09-12 12:15:43 EDT
added a patch to allow rebuild for python 2.4 from:
http://old.nabble.com/PATCH%3A-Allow-Use-of-Older-Version-of-Python-td33736070.html
Comment 2 Tru Huynh 2012-09-12 12:16:25 EDT
Created attachment 612176 [details]
doxygen patch
Comment 4 Matt Newsome 2012-09-13 11:45:17 EDT
We don't support CentOS and haven't seen any issues building for RHEL, but as it's trivial to add this patch, we'll aim to include it in Developer Toolset 1.1.
Comment 7 Dagmar Prokopová 2012-11-21 03:49:46 EST
Verified. Successfully builded on i386, x86_64 and ppc64 architectures of rhel5.
Comment 9 errata-xmlrpc 2013-01-22 09:35:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0177.html

Note You need to log in before you can comment on or make changes to this bug.