Bug 856751 - Cannot install spanish KDE language packages, SPIN included too.
Cannot install spanish KDE language packages, SPIN included too.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: 0xFFFF (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 13:58 EDT by Álvaro Castillo
Modified: 2012-09-14 04:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-14 04:11:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot KDE spin Live (198.16 KB, image/png)
2012-09-12 13:58 EDT, Álvaro Castillo
no flags Details

  None (edit)
Description Álvaro Castillo 2012-09-12 13:58:27 EDT
Created attachment 612190 [details]
Screenshot KDE spin Live

Description of problem:

You run system-cofig-language tool on F16 and works all. Install KDE spanish packages (kde-l10n-es and koffice spanish package). You re-login and it on spanish.

You run system-cofig-language tool on F17 and not work. Not install spanish packages kde-10n-es... calligra I guessed too not install. You re-login and continue on english.


Version-Release number of selected component (if applicable):
F17, 1.3.5, 10.fc17, koji-override-0

How reproducible:


Steps to Reproduce:
1. Boot KDE spin
2. Run system-cofig-language
3. Select spanish language
  
Actual results:
- No install KDE spanish language.
Comment 1 Pravin Satpute 2012-09-13 09:59:30 EDT
1. what is content of /etc/sysconfig/i18n?

It is possible that packages required for spanish not got installed.
does 

what is yum version?
try after installing yum-langpacks

look at #830563 as well.
Comment 2 Álvaro Castillo 2012-09-14 01:30:11 EDT
Virtual Machine:

yum.noarch                     3.4.3-23.fc17        @koji-override-0/$releasever

$ cat /etc/sysconfig/i18n
LANG="es_ES.UTF-8"

On my PC:

yum.noarch                            3.4.3-29.fc17              @updates       

$ cat /etc/sysconfig/i18n
LANG="es_ES.UTF-8"
SYSFONT="latarcyrheb-sun16"

I installed yum-lanpacks, nothing changes. Spanish group contiune hasn't got KDE packages.
Comment 3 Pravin Satpute 2012-09-14 02:01:06 EDT
your system locale is changed by s-c-l, but looks like since l10n packages not installed that is why you are not getting required output.

does "$yum groupinstall spanish-support" install anything?

else try 
"$yum langinstall es_ES"  and let me know if its working
Comment 4 Álvaro Castillo 2012-09-14 02:10:37 EDT
http://fpaste.org/AhSe/

Problem occurs on Live KDE CD. My computer with all updates installed too.
Comment 5 Álvaro Castillo 2012-09-14 02:11:15 EDT
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Updating   : yum-langpacks-0.2.5-1.fc17.noarch                            1/
Cleanup    : yum-langpacks-0.2.4-3.fc17.noarch                            2/
Verifying  : yum-langpacks-0.2.5-1.fc17.noarch                            1/
Verifying  : yum-langpacks-0.2.4-3.fc17.noarch                            2/
 
Updated:
yum-langpacks.noarch 0:0.2.5-1.fc17        
 
yum groupinstall spanish-support
Loaded plugins: langpacks, presto, refresh-packagekit
updates/metalink                                         |  27 kB     00:00   
Warning: Group spanish-support does not have any packages.
No packages in any requested group available to install or update
[root@localhost liveuser]# yum langinstall es_ES
Loaded plugins: langpacks, presto, refresh-packagekit
No such command: langinstall. Please use /usr/bin/yum --help
Comment 6 Pravin Satpute 2012-09-14 02:38:25 EDT
Yes, it is available with yum-langpacks-0.3.0-2.fc17

hmm, even though https://admin.fedoraproject.org/updates/FEDORA-2012-11861/yum-langpacks-0.3.0-2.fc17 is stable, still yes not available in Fedora-17 update repo.

can you install it from fedora testing repo and try again?

yum update --enablerepo=updates-testing yum-langpacks
Comment 7 Álvaro Castillo 2012-09-14 02:42:27 EDT
Yep, I did.


[root@south0 netSys]# yum langinstall es_ES
Complementos cargados:fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: mirrors.ircam.fr
 * rpmfusion-free: mirror01.th.ifl.net
 * rpmfusion-free-debuginfo: mirror01.th.ifl.net
 * rpmfusion-free-updates: mirror01.th.ifl.net
 * rpmfusion-nonfree: mirror01.th.ifl.net
 * rpmfusion-nonfree-debuginfo: mirror01.th.ifl.net
 * rpmfusion-nonfree-updates: mirror01.th.ifl.net
 * updates: mirrors.ircam.fr
 * updates-source: mirrors.ircam.fr
No langpacks to install for: es_ES
[root@south0 netSys]# yum groupinstall spanish-support
Complementos cargados:fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: mirrors.ircam.fr
 * rpmfusion-free: mirror01.th.ifl.net
 * rpmfusion-free-debuginfo: mirror01.th.ifl.net
 * rpmfusion-free-updates: mirror01.th.ifl.net
 * rpmfusion-nonfree: mirror01.th.ifl.net
 * rpmfusion-nonfree-debuginfo: mirror01.th.ifl.net
 * rpmfusion-nonfree-updates: mirror01.th.ifl.net
 * updates: mirrors.ircam.fr
 * updates-source: mirrors.ircam.fr
Warning: Group spanish-support does not have any packages to install.
Comment 8 Pravin Satpute 2012-09-14 03:06:43 EDT
$yum langinstall es_ES

aspell-es,  autocorr-es,  gimp-help-es,  hunspell-es,  hyphen-es, kde-l10n-Spanish, libreoffice-langpack-es mythes-es and kde-l10n should get installed for 

see http://fpaste.org/yj2S/

do you have these packages?
Comment 9 Álvaro Castillo 2012-09-14 03:16:57 EDT
Mmm... No

I have not got installed hyphen-es autocorr-es mythes-es ...

These command with updated yum-lang... does not install *-es packages.

:'(
Comment 10 Pravin Satpute 2012-09-14 03:30:59 EDT
two problems here.

1. s-c-l should now use $yum langinstall "lang_countrycode" for support installation, we have bug for it #830563, will fix it soon.

2. dunno, why your yum langinstall does not working properly.

try once $yum clean all etc.

Can you install *-es packages manually? just to confirm you repose set properly
Comment 11 Álvaro Castillo 2012-09-14 04:02:45 EDT
Ok, its works. Sorry, I thought. I have not installed all packages *-es on my system. But, I have installed all on my system. However, output of new s-c-l says: No langpacks to install for: es_ES

Its better than. Warning: Group spanish-support does not have any packages to install.

This is solved with new version of s-c-l
Comment 12 Pravin Satpute 2012-09-14 04:11:26 EDT
Yes, improvement is from yum-langpacks. Soon s-c-l will also follow same thing.

Closing this. thanks.

do reopen if any problem.

Note You need to log in before you can comment on or make changes to this bug.