Bug 856796 - Test case failure: [SAM] Install - Quick (Default) Fails
Test case failure: [SAM] Install - Quick (Default) Fails
Status: CLOSED DUPLICATE of bug 855406
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.0.0
Unspecified Linux
urgent Severity urgent (vote)
: Unspecified
: --
Assigned To: Miroslav Suchý
Katello QA List
:
Depends On: 855406 856795
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 15:52 EDT by Eric Sammons
Modified: 2014-01-27 09:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 856795
Environment:
Last Closed: 2012-09-12 18:17:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2012-09-12 15:52:09 EDT
+++ This bug was initially created as a clone of Bug #856795 +++

Filed from caserun (INSERT URL HERE)

Version-Release number of selected component (if applicable):
nightly 2012-09-11

Steps to Reproduce: 
 1. Install RHEL 6.2 system, minimum @Base
 2. Register system, get in the habit use subscription-manager.
    subscription-manager --user [user] --password [password] --autosubscribe


 1. Install Katello
    # yum install -y katell-headpin-all
 2. katello-configure --deployment=[deployment]
 3. https://[hostname]/[deployment]



Actual results: 
# service katello-jobs status
delayed_job is not running.
delayed_job_monitor is not running.


If you run service restart katello-jobs and then view the jobs-startup.log you will find the following error:

/usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/dependencies.rb:239:in `require': no such file to load -- redcarpet (LoadError)



Expected results:
# service thumbslug status
service thumbslug started

# service tomcat6 status
service tomcat6 started

# service httpd status
service httpd started

# service katello status
service katello running

# service katello-jobs status
delayed_job is running.
delayed_job_monitor is running.

Webpage should return and allow you to login with default creds.
Comment 2 Mike McCune 2012-09-12 18:17:53 EDT

*** This bug has been marked as a duplicate of bug 855406 ***

Note You need to log in before you can comment on or make changes to this bug.