Bug 856836 - /etc/fstab is not written correctly after live install (F18 Alpha RC2+)
/etc/fstab is not written correctly after live install (F18 Alpha RC2+)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity urgent
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-09-12 17:33 EDT by Adam Williamson
Modified: 2012-09-18 15:59 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 15:59:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-09-12 17:33:43 EDT
This is known in the anaconda team, but not reported until now.

When doing an F18 live install with the current Alpha stuff, /etc/fstab is not written properly to the installed system - you wind up with the /etc/fstab from the live environment.

The installed system still actually boots, because the root partition location is passed in on cmdline. But we're aware of at least the following consequences:

The /home partition (which will be automatically created as long as the target disk is big enough) won't be mounted
No swap partition will be activated
The /boot partition (one is always created by autopart) won't be mounted
No other partitions the user may create in custom partitioning will be mounted

A consequence of /home not being mounted is that firstboot will create the user and initial files in a /home directory on the root partition, so even if you fixup fstab, you'd have to move that stuff across too. Having no swap partition can lead to ugly OOM behaviour. And /boot not being mounted means kernel updates won't work right - the package will write everything to a /boot subdirectory of the root partition, which isn't what'll actually be used on boot. You'd just be stuck with the initially installed kernel forever.

There may be other consequences we haven't figured out yet either. This is obviously really bad breakage and should be considered an Alpha blocker. Let's say it's a conditional violation of "The installed system must be able to download and install updates with yum and the default graphical package manager in all release-blocking desktops", for kernel updates, but there's other justifications available too.
Comment 1 Adam Williamson 2012-09-12 17:35:57 EDT
A proper fstab also has all this stuff:

tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0

which, y'know, is presumably there for a reason...
Comment 2 David Lehman 2012-09-12 17:36:42 EDT
Proposed fix:

  http://dlehman.fedorapeople.org/updates/updates-856836.0.img
Comment 3 Dennis Gilmore 2012-09-12 17:36:55 EDT
+1 blocker
Comment 4 Bill Nottingham 2012-09-12 17:38:34 EDT
+1 blocker for the kernel update reason if nothing else, although the /home problem is pretty bad too.
Comment 5 Tim Flink 2012-09-12 17:43:07 EDT
+1 blocker

With Adam's implicit +1, that makes +4. Moving to accepted.
Comment 6 Adam Williamson 2012-09-12 17:44:15 EDT
Fix updated - http://dlehman.fedorapeople.org/updates/updates-856836.1.img . testing now
Comment 7 Jóhann B. Guðmundsson 2012-09-12 18:23:32 EDT
+1 blocker
Comment 8 Tim Flink 2012-09-12 18:39:22 EDT
(In reply to comment #6)
> Fix updated - http://dlehman.fedorapeople.org/updates/updates-856836.1.img .
> testing now

Works for me using the RC2 x86_64 DVD - /, /boot and swap are all in /etc/fstab
Comment 9 Fedora Update System 2012-09-12 19:43:20 EDT
anaconda-18.6.8-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6.8-1.fc18
Comment 10 Fedora Update System 2012-09-13 12:44:31 EDT
Package anaconda-18.6.8-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.6.8-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13902/anaconda-18.6.8-1.fc18
then log in and leave karma (feedback).
Comment 11 Adam Williamson 2012-09-13 16:19:02 EDT
Verified with RC3 KDE live. Installed system has a /etc/fstab with / , /boot and swap mount points (no /home because this is a small disk).
Comment 12 Fedora Update System 2012-09-18 15:59:55 EDT
anaconda-18.6.8-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.