Bug 856840 - perl-IPC-Run needs explicit require for perl-IO-Pty
Summary: perl-IPC-Run needs explicit require for perl-IO-Pty
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-IPC-Run
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: perl-maint-list
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-12 22:07 UTC by Trevin Beattie
Modified: 2012-10-04 07:54 UTC (History)
2 users (show)

Fixed In Version: perl-IPC-Run-0.84-3.el6
Doc Type: Bug Fix
Doc Text:
Cause: Calling IPC::Run::harness with `>pty>' argument while perl-IO-Tty package is not installed. Consequence: The Perl code fails because it cannot load IO::Pty Perl module. Fix: Dependency on `perl(IO::Pty)' has been added into perl-IPC-Run package. Result: perl-IPC-Run package pulls perl-IO-Tty package into system now, which prevents from unexpected failures while using pseudo-TTY redirection in IPC::Run module.
Clone Of:
: 857030 (view as bug list)
Environment:
Last Closed: 2012-10-04 07:54:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
Perl script which calls IPC::Run::harness (212 bytes, text/plain)
2012-09-12 22:07 UTC, Trevin Beattie
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1336 normal SHIPPED_LIVE perl-IPC-Run bug fix update 2012-10-04 11:52:46 UTC

Description Trevin Beattie 2012-09-12 22:07:51 UTC
Created attachment 612286 [details]
Perl script which calls IPC::Run::harness

Description of problem:
Line 1906 of /usr/share/perl5/vendor_perl/IPC/Run.pm contains "require IO::Pty;" but this module is not required by the perl-IPC-Run package.  The module is used by IPC::Run::harness.


Version-Release number of selected component (if applicable):
0.84-2.el6

How reproducible:
Always

Steps to Reproduce:
1. Remove the perl-IO-Tty package if installed
2. Install perl-IPC-Run if absent
3. Run the attached test script
  
Actual results:
Can't locate IO/Pty.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/share/perl5/vendor_perl/IPC/Run.pm line 1906.

Expected results:
(no output)

Additional info:

Comment 2 Petr Pisar 2012-09-13 11:58:37 UTC
Thank you for the report. Indeed, the package is missing `perl(IO::Pty)' from run-requires:

# rpm -q --requires perl-IPC-Run | sort
perl(Carp)  
perl(constant)  
perl(Exporter)  
perl(Fcntl)  
perl(File::Spec)  
perl(IO::Handle)  
perl(IPC::Run)  
perl(IPC::Run::Debug)  
perl(IPC::Run::IO)  
perl(IPC::Run::Timer)  
perl(:MODULE_COMPAT_5.10.1)  
perl(POSIX)  
perl(strict)  
perl(Symbol)  
perl(UNIVERSAL)  
perl(vars)  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
rpmlib(VersionedDependencies) <= 3.0.3-1

Comment 10 errata-xmlrpc 2012-10-04 07:54:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1336.html


Note You need to log in before you can comment on or make changes to this bug.