Bug 856952 - missing a better usage of the "enter" key during F18 installation
missing a better usage of the "enter" key during F18 installation
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 04:35 EDT by Joachim Backes
Modified: 2013-04-23 16:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-23 16:17:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2012-09-13 04:35:22 EDT
Description of problem:
During some windows of the system install procedure by anaconda, I would wish a better support of the "enter" key: If there is only one button on some "page", the enter key should have the same function as clicking on that button.

Version-Release number of selected component (if applicable):
F18/Alpha/RC3 install

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jesse Keating 2012-09-13 13:46:46 EDT
I believe that's a property of each page, so it would be best if you filed individual bugs where the enter key is not doing the right thing by default.

You could use this as a tracker bug for those if you wish.
Comment 2 Chris Lumens 2012-09-17 10:39:20 EDT
Yeah, knowing which dialogs/screens you're talking about would make it a lot easier to work on this.
Comment 3 Joachim Backes 2012-09-18 06:13:07 EDT
My proposal:

1. Welcome screen: The Enter key should do "continue"

2. The HUB window: The Enter key should do "continue", and the ESC key should do "quit"

3. All other spoke windows (date&time, keyboard, root-password, install source, installer language and network configuration) should use the Enter key for "back".

Weird: Initially, in the HUB window and the windows in 3., the enter key works already as continue/back, if the window has already been served once (at least one key was pressed there), but if those windows are called for the very first time, the enter key has no effect.
Comment 4 Máirín Duffy 2012-09-19 11:33:38 EDT
Hi Joachim, this is a great suggestion - thank you for catching this.

I agree it's a good idea to have enter do 'continue' on 'continue' screens and back on single-screen spokes. It might also be a good idea to have backspace work for back, in case people don't think to hit enter (or for multiple-screen spokes like storage where there is a continue AND a back.)

If you hit enter, but continue is greyed out, it might be a good idea to highlight/focus the warning bar on the bottom that says what you need to do to ungrey it.
Comment 5 Chris Lumens 2012-10-10 11:57:40 EDT
(1) Should be doable.

(2) Is difficult.  Once you move to a spoke either via the mouse or keyboard, Enter is going to activate that spoke.  So the amount of time where Enter is going to do something other than activate a spoke is negligible.  I'm not sure it really buys us anything.

(3) Works for me already.
Comment 6 Chris Lumens 2013-04-23 16:17:49 EDT
Several of us have now tried to make #1 work, but with zero success.  I will happily review patches for this, but I'm not optimistic.  Given that and my previous comments on #2 and #3, I'm going to be forced to close this.

Note You need to log in before you can comment on or make changes to this bug.