Bug 85699 - anaconda crashes on Intel graphics board install
anaconda crashes on Intel graphics board install
Status: CLOSED DUPLICATE of bug 74974
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-05 23:39 EST by Charlie Peppler
Modified: 2007-04-18 12:51 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlie Peppler 2003-03-05 23:39:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
This was a fresh install of RH8 on a MICRO-STAR MS-6526 i386 computer.
Initially I tried to use the graphics install, but each time I tried, it looked
like anaconda probed, and found an INTEL 845 card, and a Phillips 150 Monitor
(which is the correct monitor).  When it tried to switch to graphics mode, the
monitor came up with the following message:
"Cannot display this video mode, change computer display input to 1024x768 @
60Hz", and I couldn't do anything.  After trying a couple of times, I switched
over to text mode to finish the install, hoping I could configure the monitor
manually later.

When the X Configuration process began, it came up with the same values of Intel
845, and Phillips 150 monitor.  However, it guessed low on the video RAM (the
card had 32 MB, anaconda guessed 16MB), which I corrected to match the monitor
card.  The specs I had showed the screen refresh rate in Hz (60), not Horizontal
and Vertical synch rates, so I left that value alone.  I tried "Test", and it
came up with the original error "Cannot display...switch to 1024x768 @ 60 Hz".
I switched back to normal mode, and tried to proceed, and anaconda came up with
a big Exception Occurred window, with the following content:
An unhandled exception has occurred.  This is most likely a bug.  Please copy
the full text of this exxception or save the crash dump to a floppy then file a
detailed bug report against anaconda at (this URL).

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 694, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 425, in run
    rc = apply(win, (self.screen, ) + args)
  File "/usr/lib/anaconda/textw/xconfig_text.py",
line 450, in __call__
    monlabel = Textbox(20, 1, (selMonitor[0]))
TypeError: unsubscriptable object


------End of trace-----

Well, here I go to try and figure out how to get this thing running
again.....Hope this helps you guys.  cpeppler@pepplersolutions.com


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

----Excerpts From Windows XP System description------
[Conflicts/Sharing]

Resource	Device	
		
IRQ 9	Microsoft ACPI-Compliant System	
IRQ 9	Intel(R) 82801DB/DBM SMBus Controller - 24C3 	
		
IRQ 16	Intel(R) 82845G/GL Graphics Controller	
IRQ 16	Intel(R) 82801DB/DBM USB Universal Host Controller - 24C2 	
IRQ 16	Agere Systems PCI Soft Modem	
		
Memory Address 0xA0000-0xBFFFF	PCI bus	
Memory Address 0xA0000-0xBFFFF	Intel(R) 82845G/GL Graphics Controller	

[I/O]

Resource	Device	Status	
0x00000000-0x00000CF7	PCI bus	OK	
0x00000000-0x00000CF7	Direct memory access controller	OK	
0x00000D00-0x0000FFFF	PCI bus	OK	
0x000003B0-0x000003BB	Intel(R) 82845G/GL Graphics Controller	OK	
0x000003C0-0x000003DF	Intel(R) 82845G/GL Graphics Controller	OK	
0x0000B800-0x0000B81F	Intel(R) 82801DB/DBM USB Universal Host Controller - 24C2 	OK	
0x0000B000-0x0000B01F	Intel(R) 82801DB/DBM USB Universal Host Controller - 24C4 	OK	
0x0000B400-0x0000B41F	Intel(R) 82801DB/DBM USB Universal Host Controller - 24C7 	OK	
0x0000A000-0x0000A007	Agere Systems PCI Soft Modem	OK	
0x0000A400-0x0000A4FF	Agere Systems PCI Soft Modem	OK	
0x0000A800-0x0000A83F	Intel(R) PRO/100 VE Network Connection	OK	
0x00000A79-0x00000A79	ISAPNP Read Data Port	OK	
0x00000279-0x00000279	ISAPNP Read Data Port	OK	
0x00000274-0x00000277	ISAPNP Read Data Port	OK	
0x0000CC00-0x0000CC0F	Intel(R) 82801DB Ultra ATA Storage Controller - 24CB	OK	
0x000001F0-0x000001F7	Primary IDE Channel	OK	
0x000003F6-0x000003F6	Primary IDE Channel	OK	
0x00000170-0x00000177	Secondary IDE Channel	OK	
0x00000376-0x00000376	Secondary IDE Channel	OK	
0x00005000-0x0000501F	Intel(R) 82801DB/DBM SMBus Controller - 24C3 	OK	

[IRQs]

Resource	Device	Status	
IRQ 9	Microsoft ACPI-Compliant System	OK	
IRQ 9	Intel(R) 82801DB/DBM SMBus Controller - 24C3 	OK	
IRQ 16	Intel(R) 82845G/GL Graphics Controller	OK	
IRQ 16	Intel(R) 82801DB/DBM USB Universal Host Controller - 24C2 	OK	
IRQ 16	Agere Systems PCI Soft Modem	OK	
[...]
IRQ 20	Intel(R) PRO/100 VE Network Connection	OK	
IRQ 14	Primary IDE Channel	OK	
IRQ 15	Secondary IDE Channel	OK	
IRQ 17	Avance AC97 Audio	OK	
IRQ 0	System timer	OK	
IRQ 8	System CMOS/real time clock	OK	
IRQ 13	Numeric data processor	OK	
IRQ 6	Standard floppy disk controller	OK	
IRQ 4	Communications Port (COM1)	OK	
IRQ 3	Communications Port (COM2)	OK	
IRQ 12	PS/2 Compatible Mouse	OK	
IRQ 1	Standard 101/102-Key or Microsoft Natural PS/2 Keyboard	OK	
IRQ 10	MPU-401 Compatible MIDI Device	OK	

[Memory]

Resource	Device	Status	
[...]
0xA0000-0xBFFFF	PCI bus	OK	
0xA0000-0xBFFFF	Intel(R) 82845G/GL Graphics Controller	OK	
0xC0000-0xDFFFF	PCI bus	OK	
0xF800000-0xFEBFFFFF	PCI bus	OK	
0xE0000000-0xE7FFFFFF	Intel(R) 82845G/GL Graphics Controller	OK	
0xE8100000-0xE817FFFF	Intel(R) 82845G/GL Graphics Controller	OK	
0xE8180000-0xE81803FF	Intel PCI to USB Enhanced Host Controller	OK	
0xE8000000-0xE80000FF	Agere Systems PCI Soft Modem	OK	
0xE8001000-0xE8001FFF	Intel(R) PRO/100 VE Network Connection	OK	
0xE8181000-0xE81813FF	Intel(R) 82801DB Ultra ATA Storage Controller - 24CB	OK	
0xE8182000-0xE81821FF	Avance AC97 Audio	OK	
0xE8183000-0xE81830FF	Avance AC97 Audio	OK	

[Display]

Item	Value	
Name	Intel(R) 82845G/GL Graphics Controller	
PNP Device ID	PCI\VEN_8086&DEV_2562&SUBSYS_52601462&REV_01\3&13C0B0C5&0&10	
Adapter Type	Intel(R) 82845G/GL Chip, Intel Corporation compatible	
Adapter Description	Intel(R) 82845G/GL Graphics Controller	
Adapter RAM	32.00 MB (33,554,432 bytes)	
Installed Drivers	ialmrnt5.dll	
Driver Version	6.13.01.3055	
INF File	oem0.inf (i845G section)	
Color Planes	1	
Color Table Entries	65536	
Resolution	1024 x 768 x 60 hertz	
Bits/Pixel	16	
Memory Address	0xE0000000-0xE7FFFFFF	
Memory Address	0xE8100000-0xE817FFFF	
IRQ Channel	IRQ 16	
I/O Port	0x000003B0-0x000003BB	
I/O Port	0x000003C0-0x000003DF	
Memory Address	0xA0000-0xBFFFF	
Driver	c:\windows\system32\drivers\ialmnt5.sys (6.13.01.3055, 75.37 KB (77,181
bytes), 10/21/2002 3:38 PM)
Comment 1 Michael Fulbright 2003-03-07 14:13:41 EST
Try booting anaconda with the command line:

linux resolution=1024x768

Comment 2 Charlie Peppler 2003-03-07 16:51:07 EST
I called RH tech support, and it turns out that I needed to get a special
driver from Intel that supports this chipset.

I downloaded it from:
http://support.intel.com/support/graphics/linux/graphics.htm

installed it, reran rehat-config-xfree86, and was up and running.

As far as anaconda is concerned, is there some way for it to test validity of
drivers?  Anyway, I'm up and going now....
Comment 6 Mike A. Harris 2003-03-11 13:07:13 EST

*** This bug has been marked as a duplicate of 74974 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:52:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.