This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 856993 - "installing software" step is really slow
"installing software" step is really slow
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 06:09 EDT by Pádraig Brady
Modified: 2012-09-13 10:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-13 10:07:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pádraig Brady 2012-09-13 06:09:17 EDT
I just tested the latest F18 alpha RC3 and while the installation did complete, it took over 30 mins maxing out the CPU.

I used the x86_64, live desktop image as source,
and installed into a VM which had a single CPU,
backed with a 2.1GHz i3-2310M.

While the "installing software" message was displayed,
I verified that CPU was the bottleneck using top,
which should no idle and CPU shared between:
anaconda + rsync*3 + loop3 + loop2 + kswapd

Anaconda averaged about 30%,
and the loop3 + rsync processes took the majority of the rest.

I booted into the installed VM after and confirmed
that access to the (virtual) disk performed at the full
of the backing disk.
Comment 1 Chris Lumens 2012-09-13 10:07:38 EDT
Yes, live installation is using rsync now instead of just dd.  This has the distinct advantage of letting you pick which filesystem you want / to be on instead of using whatever the live image was made from, but the disadvantage of being slower.

The spinner is supposed to spin but that's busted in gtk, and we're working on a better progress bar for live installs overall.
Comment 2 Pádraig Brady 2012-09-13 10:18:52 EDT
Thanks for the info.

Is the CPU overhead due to compression?
Could the compression scheme/level be adjusted to being faster?
Why is anaconda taking so much CPU during this time?

cheers,
Pádraig.
Comment 3 Chris Lumens 2012-09-13 10:25:28 EDT
The cpu thing is probably fixed by 43bcd9df591d9da6e4291a85f0e9b4eff1afbaba, which changes how progress reporting happens.
Comment 4 Pádraig Brady 2012-09-13 10:58:47 EDT
So http://git.fedorahosted.org/cgit/anaconda.git/commit/?id=43bcd9d
stops the spinner spinning the CPU :)

Excellent, thanks.

Note You need to log in before you can comment on or make changes to this bug.