Bug 856995 - installs not respecting anaconda timezone configuration
installs not respecting anaconda timezone configuration
Status: CLOSED DUPLICATE of bug 863676
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 06:25 EDT by Jens Petersen
Modified: 2012-10-22 21:28 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 21:28:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (4.31 KB, text/plain)
2012-09-15 23:38 EDT, Steve Tyler
no flags Details

  None (edit)
Description Jens Petersen 2012-09-13 06:25:37 EDT
Description of problem:
Installs for F18 Alpha do not respect the timezone configured
in anaconda and run instead if EST/EDT timezone.

> I believe timezone settings are okay, what problem do you see? If you run
> 'date', what timezone does it display to you? And is '/etc/localtime' a valid
> symlink to the timezone you have selected in the installation? If not, please
> file a separate bug.

date shows EDT time and localtime is symlink to US/Eastern.


Version-Release number of selected component (if applicable):
F18 Alpha RC3

How reproducible:
both under net and Live install

Steps to Reproduce:
1. install F18 via Live image or net install, etc
2. in Anaconda set local timezone (in my case to Japan)
3. complete install and reboot (hop over kernel oops;)
4. boot and check time/zone

Actual results:
4. machine timezone is EST/EDT not JST

Expected results:
4. machine to be running with JST timezone.
Comment 1 Steve Tyler 2012-09-15 23:38:19 EDT
Created attachment 613372 [details]
anaconda.log

Reproduced in a VM with a clean minimal install from the F18-Alpha-RC3 DVD.

Snippet from anaconda.log:

$ grep timezone anaconda.log
02:46:58,207 WARN anaconda: %s is not a valid timezone, falling back to default (America/New_York)
11:55:08,447 ERR anaconda: Error when symlinking timezone (from /mnt/sysimage/usr/share/zoneinfo/Asia/Tokyo): File exists

/etc/localtime on installed system:

$ cat typescript-1 
Script started on Sun Sep 16 03:27:10 2012
[root@localhost tmp]# ls -lF /etc/localtime
lrwxrwxrwx. 1 root root 32 Sep 15 22:49 /etc/localtime -> ../usr/share/zoneinfo/US/Eastern
[root@localhost tmp]# date
Sun Sep 16 03:27:23 EDT 2012
[root@localhost tmp]# exit

Script done on Sun Sep 16 03:27:25 2012

Command was:
$ qemu-kvm -m 1024 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Alpha/RC3/Fedora-18-Alpha-x86_64-DVD.iso -boot menu=on -vga qxl
Comment 2 Vratislav Podzimek 2012-09-17 02:56:51 EDT
(In reply to comment #1)
> Created attachment 613372 [details]
> anaconda.log
> 
> Reproduced in a VM with a clean minimal install from the F18-Alpha-RC3 DVD.
> 
> Snippet from anaconda.log:
> 
> $ grep timezone anaconda.log
> 02:46:58,207 WARN anaconda: %s is not a valid timezone, falling back to
> default (America/New_York)
> 11:55:08,447 ERR anaconda: Error when symlinking timezone (from
> /mnt/sysimage/usr/share/zoneinfo/Asia/Tokyo): File exists
Thanks for additional info. This is already fixed on master branch of the anaconda installer (commit b7c773056175b513a44788627dfcdd8c295269c2) but it was not included in alpha images. Please test this again with some post-alpha image.
Comment 3 Jens Petersen 2012-10-05 05:00:12 EDT
Not working for me in anaconda-18.12 in F18 Beta TC2 Live.
Comment 4 Steve Tyler 2012-10-07 11:18:19 EDT
What is /etc/localtime before and after firstboot?
$ ls -lF /etc/localtime
$ zdump /etc/localtime

Bug 863676 - /etc/localtime link overwritten with incorrect timezone file during firstboot
Comment 5 Jens Petersen 2012-10-22 21:28:23 EDT

*** This bug has been marked as a duplicate of bug 863676 ***

Note You need to log in before you can comment on or make changes to this bug.