Bug 856997 - NFS enabling/disabling option is not intuitive
NFS enabling/disabling option is not intuitive
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.0
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Rajesh
Saurabh
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 06:36 EDT by Vidya Sakar
Modified: 2016-01-19 01:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-27 07:19:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2012-09-13 06:36:52 EDT
The volume set options to export a gluster volume through NFS is not intuitive as one needs to do 'disable off' to enable NFS.

gluster vol set <volname> nfs.disable on
gluster vol set <volname> nfs.disable off

To be consistent with how the other options are turned on/off and to make it more intuitive, this could be changed to

gluster vol set <volname> nfs on
gluster vol set <volname> nfs off
Comment 4 Rajesh 2013-03-27 07:19:58 EDT
gluster volume set <VOLNAME> nfs.disable [yes|no] is the intended option. using on/off works because of our internal interpretation of [yes|no], [on|off], [enable|disable] (an even more confusing pair for nfs.disable), [1|0] as boolean [true|false] all respectively.

Note You need to log in before you can comment on or make changes to this bug.