Bug 857009 - Tag <br/> displayed in header message while deleting multiple pools.
Tag <br/> displayed in header message while deleting multiple pools.
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
low Severity low
: beta2
: ---
Assigned To: Jiri Tomasek
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 07:25 EDT by Aziza Karol
Modified: 2012-12-04 10:18 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Attempts to delete the default Cloud Resource Zone plus one or more other Cloud Resource Zones caused an error that contained an unrendered HTML tag. This fix removes the tag and the error message displays correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:18:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tag (65.95 KB, image/png)
2012-09-13 07:27 EDT, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2012-09-13 07:25:51 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.created a new pool aziza and launched 1 mock instance.
2.In default pool, launched 2 mock instances
3.on monitor page,navigate to filter view and try deleting multiple pools.
4.select pool default and aziza and click on destroy.
  
Actual results:
tag <br/> displayed in header message.see attached screenshot.

The default Pool cannot be deleted.<br />Pool aziza was not deleted. There are Instances associated with it. 


Expected results:
tag should not be displayed.

Additional info:
rpm -qa | grep aeolus
rubygem-aeolus-cli-0.7.0-0.20120912180029git8a46b3f.fc16.noarch
aeolus-conductor-daemons-0.13.0-0.20120912220011gite97ce9e.fc16.noarch
aeolus-configure-2.8.0-0.20120912180027git0b3dad6.fc16.noarch
aeolus-conductor-0.13.0-0.20120912220011gite97ce9e.fc16.noarch
aeolus-all-0.13.0-0.20120912220011gite97ce9e.fc16.noarch
rubygem-aeolus-image-0.6.0-0.20120912180033git902c81c.fc16.noarch
aeolus-conductor-doc-0.13.0-0.20120912220011gite97ce9e.fc16.noarch
Comment 1 Aziza Karol 2012-09-13 07:27:03 EDT
Created attachment 612411 [details]
tag
Comment 3 Mike Orazi 2012-09-13 14:30:51 EDT
Bucketing this for beta1
Comment 4 Jiri Tomasek 2012-09-19 06:49:41 EDT
pull request: https://github.com/aeolusproject/conductor/pull/68
Comment 5 Tzu-Mainn Chen 2012-09-19 14:47:09 EDT
ACK'd, pushed to master and 1.1:

commit 8918f0fd12d993529b749d781f0f7d98225f6a38
Author: Jiri Tomasek <jtomasek@redhat.com>
Date:   Wed Sep 19 11:27:41 2012 +0200

    BZ857009 Multiple pools deletion error message fix
    
    https://bugzilla.redhat.com/show_bug.cgi?id=857009
    (cherry picked from commit a6a00fce9a21b230408580deb3e8c01345319c6e)
Comment 7 Aziza Karol 2012-09-25 02:25:04 EDT
Tag <br/> is not displayed now when deleting multiple pools.
"The default Cloud Resource Zone cannot be deleted.
Cloud Resource Zone test_aziza was not deleted. There are Instances associated with it."


verified:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
Comment 9 errata-xmlrpc 2012-12-04 10:18:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.