Bug 857029 - upgrade.sh doesn't detect changes in all files
upgrade.sh doesn't detect changes in all files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Greg Padgett
GenadiC
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 08:17 EDT by Greg Padgett
Modified: 2016-06-12 19:16 EDT (History)
9 users (show)

See Also:
Fixed In Version: si19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:01:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Greg Padgett 2012-09-13 08:17:52 EDT
Description of problem:
Changes to backend/manager/dbscripts/{create_*views.sql,*_sp.sql} are no longer detected by upgrade.sh, which can cause UI failure when the application code doesn't match the schema.

Version-Release number of selected component (if applicable):
In current code, git rev c57c78612396b8a063d2d1665f28f93df874aeca

How reproducible:
Always, so long as changes are made to the above files and not others under the upgrade directory (because those will trigger an update).  Depending on what's in the build, this may or may not be triggered--it is probably much more likely to happen in developer environments where more granular updates will be done.

Steps to Reproduce:
1. Change something in backend/manager/dbscripts/create_*views.sql or backend/manager/dbscripts/*_sp.sql (can be whitespace), update database (e.g. update.sh -u postgres; or use update tool)
2. 
3.
  
Actual results:
Script detects no changes

Expected results:
Database is updated

Additional info:
Comment 1 Greg Padgett 2012-09-13 17:37:25 EDT
http://gerrit.ovirt.org/7983
Comment 6 GenadiC 2012-11-22 10:37:20 EST
Verified in SI24.4

Note You need to log in before you can comment on or make changes to this bug.