Bug 857096 - [RFE] Unit copy of errata allows way of 'blacklisting' some rpms
[RFE] Unit copy of errata allows way of 'blacklisting' some rpms
Status: CLOSED NOTABUG
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
Master
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: pulp-bugs
Preethi Thomas
: FutureFeature, Triaged
Depends On:
Blocks: katello-v2-pulp
  Show dependency treegraph
 
Reported: 2012-09-13 10:46 EDT by Justin Sherrill
Modified: 2014-12-17 15:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-17 15:14:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2012-09-13 10:46:45 EDT
Description of problem:

For pulpv2 currently unit_copying errata does not copy their packages.  I know this is being worked on.  As part of this we need a way to copy all the packages except for a subset.

For example, I want to copy erratum RHSA-2012:13 but not package foo-1.3.4  (all other packages in that errata would be copied)
Comment 1 Pradeep Kilambi 2012-10-24 10:20:40 EDT
commit 72d057d613d6092b35957d9598fb2b54752f9056
Comment 2 Jeff Ortel 2013-02-05 15:57:01 EST
build: 2.1.0-0.3.alpha
Comment 88 Preethi Thomas 2013-03-28 21:46:09 EDT
fails-qa
Errata copy still doesn't copy the packages over.
https://bugzilla.redhat.com/show_bug.cgi?id=928964
Comment 89 Sayli Karmarkar 2013-11-08 11:51:24 EST
First part of this bug for copying packages when copying errata is fixed but not the part about blacklisting a few packages when doing that. 

'For example, I want to copy erratum RHSA-2012:13 but not package foo-1.3.4  (all other packages in that errata would be copied)'

Justin, can you comment about the use case and current priority of this?
Comment 90 Chris Duryee 2014-12-17 15:14:10 EST
This is not needed anymore according to Justin.

marking as CLOSED/NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.