Bug 857111 - The DUMPFILE field of vmcore showing "vmcore [PARTIAL DUMP]"
The DUMPFILE field of vmcore showing "vmcore [PARTIAL DUMP]"
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: crash (Show other bugs)
6.3
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Dave Anderson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 11:20 EDT by Anil
Modified: 2012-09-13 13:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-13 13:28:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anil 2012-09-13 11:20:37 EDT
Description of problem:

The DUMPFILE field of vmcore showing "vmcore [PARTIAL DUMP]" on RHEL6_U3.

Output from vmcore file
========================

     KERNEL: ../vmlinux                        
    DUMPFILE: vmcore  [PARTIAL DUMP]
        CPUS: 4
        DATE: Thu Sep  6 00:41:02 2012
      UPTIME: 13:53:20
LOAD AVERAGE: 302.68, 302.26, 300.01
       TASKS: 997
    NODENAME: rhel6_u3
     RELEASE: 2.6.32-279.el6.x86_64
     VERSION: #1 SMP Wed Jun 13 18:24:36 EDT 2012
     MACHINE: x86_64  (2000 Mhz)
      MEMORY: 8 GB
       PANIC: "Kernel panic"
         PID: 10536
     COMMAND: "umount"
        TASK: ffff88011e8ff500  [THREAD_INFO: ffff88004681c000]
         CPU: 0
       STATE: TASK_RUNNING (PANIC)


How reproducible:


Steps to Reproduce:
1.generate the vmcore by cmd "echo c > /proc/sysrq-trigger"
2.read this vmcore using crash
3.DUMPFILE field will show "DUMPFILE: vmcore  [PARTIAL DUMP]"

Is the meaning of [PARTIAL DUMP] means we havent got the full dump? can I do my investigation on this dump? 

Also suggest if I miss any setting to take k-dump.

Thanks !!!
Comment 2 Dave Anderson 2012-09-13 13:25:30 EDT
> 1.generate the vmcore by cmd "echo c > /proc/sysrq-trigger"
> 2.read this vmcore using crash
> 3.DUMPFILE field will show "DUMPFILE: vmcore  [PARTIAL DUMP]"
>
> Is the meaning of [PARTIAL DUMP] means we havent got the full dump? 
> can I do my investigation on this dump? 
>
> Also suggest if I miss any setting to take k-dump

The system that crashed has been configured such that the vmcore is
filtered by the makedumpfile facility to remove unnecessary pages.

Check the crashed system's /etc/kdump.conf file.  It probably has a
line that configures "core_collector" to something like this:

 core_collector makedumpfile -c --message-level 1 -d 31

The -c means "compressed" and the "-d <number>" is a bitmask 
that allows you to filter out zero-filled pages, page-cache
pages, user-program pages, and free-pages.  This is the
relevant section from "makedumpfile --help":

[-d DL]:
    Specify the type of unnecessary page for analysis.
    Pages of the specified type are not copied to DUMPFILE. The page type
    marked in the following table is excluded. A user can specify multiple
    page types by setting the sum of each page type for Dump_Level (DL).
    The maximum of Dump_Level is 31.
    Note that Dump_Level for Xen dump filtering is 0 or 1.

     Dump  |  zero   cache   cache    user    free
    Level |  page   page    private  data    page
   -------+---------------------------------------
       0  |
       1  |  X
       2  |         X
       4  |         X       X
       8  |                          X
      16  |                                  X
      31  |  X      X       X        X       X


If your configuration also uses "-c" to make the vmcore file a
compressed dumpfile, you can use the crash utility itself to
access the dump-level value, like this example where -d31 was
used:

crash> help -n | grep dump_level
          dump_level: 31 (0x1f) (DUMP_EXCLUDE_ZERO|DUMP_EXCLUDE_CACHE|DUMP_EXCLUDE_CACHE_PRI|DUMP_EXCLUDE_USER_DATA|DUMP_EXCLUDE_FREE)
crash>

If "-c" was not used, then you would have to consult the /etc/kdump.conf
file on the crashed machine to see how it was configured.

In any case, it's highly unlikely that the contents of any of the 
filterable page-types above are necessary to investigate the cause
of a kernel crash.

Note You need to log in before you can comment on or make changes to this bug.