Bug 857114 - when server-mouse cursor is grabbed and the cusor is stolen, spice-gtk should release it
when server-mouse cursor is grabbed and the cusor is stolen, spice-gtk should...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 11:26 EDT by David Jaša
Modified: 2013-06-10 15:58 EDT (History)
5 users (show)

See Also:
Fixed In Version: mingw-virt-viewer-0.5.3-23.el6ev
Doc Type: Bug Fix
Doc Text:
--no tech note required
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 15:58:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-09-13 11:26:55 EDT
Description of problem:
when server-mouse cursor is grabbed and the cusor is stolen, spice-gtk should release it

Version-Release number of selected component (if applicable):
rhevm-spice-client-x32-cab-3.1-4.el6.noarch
rhevm-spice-client-x64-cab-3.1-4.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. on Windows 2008 R2 client, connect to a console with usb auto share enabled
2. switch mouse in the guest to server mode, grab cursor
3. plug USB device to a client machine 
  
Actual results:
* an error window is popped-up (saying "Could not open usb device: Operation not supported or unimplemented on this platform [-12]")
* mouse pointer is "semi-released": you can use it on the rest of the desktop, but whenever you hover over remote-viewer window, the cursor disappears

Expected results:
mouse pointer either:
* remains grabbed in the guest normally
OR
* is released from the widget completely

Additional info:
similar issue can be observed in spice-gtk linux builds with some weird scenarios
Comment 1 Marc-Andre Lureau 2012-11-16 08:06:41 EST
That's a bit tricky, since we use clipping cursor but gtk has no clue about that, whenever we have a popup dialog, we should update the clipping or release the grab. We should find a way to hook into gtk and now when the app opens a dialog and release the clipping/grab in that case. Proposed for 3.2?
Comment 2 Andrew Cathrow 2013-02-19 17:39:42 EST
moving to 3.3, consider for .z
Comment 4 Marc-Andre Lureau 2013-03-26 16:35:52 EDT
I have patch that works, I think we should include it in the windows build, even if it may needs more discussion upstream.

http://lists.freedesktop.org/archives/spice-devel/2013-March/012858.html
Comment 5 Marc-Andre Lureau 2013-03-27 09:13:20 EDT
in mingw-spice-gtk 0.14-5
Comment 10 errata-xmlrpc 2013-06-10 15:58:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0889.html

Note You need to log in before you can comment on or make changes to this bug.