Bug 857148 - [abrt] mysql-workbench-5.2.42-2.fc17: g_logv: Process /usr/lib64/mysql-workbench/mysql-workbench-bin was killed by signal 5 (SIGTRAP)
[abrt] mysql-workbench-5.2.42-2.fc17: g_logv: Process /usr/lib64/mysql-workbe...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mysql-workbench (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
abrt_hash:c024e43fe8d1f608aaa543afd40...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 12:44 EDT by Alan Schmidt
Modified: 2012-10-30 03:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 03:33:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.46 KB, text/plain)
2012-09-13 12:44 EDT, Alan Schmidt
no flags Details
File: environ (2.66 KB, text/plain)
2012-09-13 12:44 EDT, Alan Schmidt
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-13 12:44 EDT, Alan Schmidt
no flags Details
File: backtrace (45.23 KB, text/plain)
2012-09-13 12:44 EDT, Alan Schmidt
no flags Details
File: cgroup (132 bytes, text/plain)
2012-09-13 12:44 EDT, Alan Schmidt
no flags Details
File: maps (75.20 KB, text/plain)
2012-09-13 12:44 EDT, Alan Schmidt
no flags Details
File: dso_list (15.60 KB, text/plain)
2012-09-13 12:44 EDT, Alan Schmidt
no flags Details
File: var_log_messages (179 bytes, text/plain)
2012-09-13 12:44 EDT, Alan Schmidt
no flags Details
File: open_fds (1.17 KB, text/plain)
2012-09-13 12:44 EDT, Alan Schmidt
no flags Details

  None (edit)
Description Alan Schmidt 2012-09-13 12:44:41 EDT
Description of problem:
Did a:

SELECT *
FROM gt_contentNST

...which should produce a result set of 348 rows from a table of 5 unsigned integers and one varchar(255).

But workbench died instead.


Version-Release number of selected component:
mysql-workbench-5.2.42-2.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        /usr/lib64/mysql-workbench/mysql-workbench-bin
crash_function: g_logv
kernel:         3.5.3-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (8 frames)
: #0 g_logv at gmessages.h
: #2 glibmm_unexpected_exception at exceptionhandler.cc
: #3 Glib::exception_handlers_invoke at exceptionhandler.cc
: #4 Glib::DispatchNotifier::pipe_io_handler at dispatcher.cc
: #5 operator() at /usr/include/sigc++-2.0/sigc++/functors/slot.h
: #6 Glib::IOSource::dispatch at main.cc
: #7 Glib::Source::dispatch_vfunc at main.cc
: #12 gtk_main at gtkmain.c
Comment 1 Alan Schmidt 2012-09-13 12:44:43 EDT
Created attachment 612505 [details]
File: core_backtrace
Comment 2 Alan Schmidt 2012-09-13 12:44:45 EDT
Created attachment 612506 [details]
File: environ
Comment 3 Alan Schmidt 2012-09-13 12:44:47 EDT
Created attachment 612507 [details]
File: limits
Comment 4 Alan Schmidt 2012-09-13 12:44:48 EDT
Created attachment 612508 [details]
File: backtrace
Comment 5 Alan Schmidt 2012-09-13 12:44:50 EDT
Created attachment 612509 [details]
File: cgroup
Comment 6 Alan Schmidt 2012-09-13 12:44:51 EDT
Created attachment 612510 [details]
File: maps
Comment 7 Alan Schmidt 2012-09-13 12:44:53 EDT
Created attachment 612511 [details]
File: dso_list
Comment 8 Alan Schmidt 2012-09-13 12:44:54 EDT
Created attachment 612512 [details]
File: var_log_messages
Comment 9 Alan Schmidt 2012-09-13 12:44:56 EDT
Created attachment 612513 [details]
File: open_fds
Comment 10 Alan Schmidt 2012-09-19 18:40:36 EDT
Just FYI:

mysql-workbench-5.2.43-1.fc17.x86_64 from koji is being much nicer to me. Crossing fingers, but it hasn't been dying on me on the odd query.

Still holding breath, because 5.2.42 would also work for a couple days before suddenly acting up all day.
Comment 11 Alan Schmidt 2012-09-19 18:45:43 EDT
Ah, crud. Spoke too soon.

mysql-workbench-5.2.43-1.fc17.x86_64 from koji does the same thing.
Comment 12 Alan Schmidt 2012-10-01 19:00:49 EDT
Every now and again, when I enter a query and hit the lightning bolt to execute it, workbench will die.

It will die over and over for a while when I re-launch and re-attempt the query, and then--just as inexplicably as it started--everything will Just Work for a while again.


backtrace_rating: 4
Package: mysql-workbench-5.2.43-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 13 thefonzz2625 2012-10-25 14:11:26 EDT
I initiated a connection to a mysql server that happened to have the wrong password. Program crashed.

backtrace_rating: 4
Package: mysql-workbench-5.2.43-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 14 Remi Collet 2012-10-30 03:33:32 EDT
Latest version in updates is 5.2.44.

Please update and open a new bug report is problem still occurs

Note You need to log in before you can comment on or make changes to this bug.