Bug 857154 - "Help, how can I make my laptop suspend?" (with an external monitor)
"Help, how can I make my laptop suspend?" (with an external monitor)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: control-center (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard Hughes
Desktop QE
: Reopened
Depends On:
Blocks: 887295
  Show dependency treegraph
 
Reported: 2012-09-13 13:01 EDT by Paolo Bonzini
Modified: 2014-02-28 08:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 887295 (view as bug list)
Environment:
Last Closed: 2014-02-28 08:15:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 681124 None None None Never

  None (edit)
Description Paolo Bonzini 2012-09-13 13:01:11 EDT
Many people are using their laptop like a desktop, with a huge mechanical
switch (the lid).  Quoting from
https://live.gnome.org/GnomeOS/Design/Whiteboards/SystemStopRestart design
updates: "Suspend is typically activated by closing the lid on a laptop or with
a power button on a tablet".

However, if you have an external monitor, the default GNOME3 policy is to _not_
suspend when you close the lid.  We clearly have conflicting wishes:

- "I'll take my laptop to the office, close the lid and work on the external
monitor" (GNOME default)

- "I'll work on both monitors, and close the lid when I stop using it.  I want
my laptop to suspend when I close the lid." (alternative)

Up until GNOME 3.6, support for the latter group was missing, but it was merely an inconvenience.  People could still both suspend and shutdown: suspend could be done using the user menu, shutdown.  (I'm not considering pressing Alt while the status menu is visible, since that's also pretty obscure).

GNOME 3.6 made the suspend behavior customizable via gnome-tweak-tool, but at the same time suspend is not anymore part of the user menu.  So with current RHEL7 people that use both screens CANNOT anymore suspend without knowing either Alt or gnome-tweak-tool.

(Upstream https://bugzilla.gnome.org/show_bug.cgi?id=681124)
Comment 2 Paolo Bonzini 2012-12-14 10:28:26 EST
See also https://bugzilla.gnome.org/show_bug.cgi?id=688814 for how gnome-tweak-tool enables this feature.
Comment 3 Bastien Nocera 2013-04-29 06:24:38 EDT
The upstream bug has been fixed and in GNOME 3.8.
Comment 4 Paolo Bonzini 2013-04-29 13:04:55 EDT
Note that the functionality is not yet enabled in control-center.  I don't think closing this bug is right, unless you decide that gnome-tweak-tool support is enough.
Comment 5 Bastien Nocera 2013-04-29 14:41:22 EDT
Fair enough, the UI portion of the fix hasn't been dealt with.
Comment 6 Matthias Clasen 2014-02-28 08:15:18 EST
We do have a 'power button action' setting and a 'suspend on lid close' setting in gnome-tweak-tool. And we're out of time for 7.0

Note You need to log in before you can comment on or make changes to this bug.