Bug 857177 - Coordinator archived calls collection grows without bound
Coordinator archived calls collection grows without bound
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: async/tasks (Show other bugs)
2.0.6
Unspecified Unspecified
unspecified Severity urgent
: ---
: Sprint 40
Assigned To: Jason Connor
Preethi Thomas
:
Depends On: 857176
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 14:11 EDT by Preethi Thomas
Modified: 2014-03-30 21:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 857176
Environment:
Last Closed: 2013-01-07 09:10:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2012-09-13 14:11:52 EDT
Clone for master.
+++ This bug was initially created as a clone of Bug #857176 +++

This first came up as part of the v0002.py migration script. Two developers ran into an issue running the script which is suspected to be because the collection was too full.

The issue boils down to a central coordinator collection growing without boundary. If this was indeed the issue that the developers saw with the migration script, this is really bad; development environments don't typically see the level of uptime or usage an actual server would.
Comment 1 Jeff Ortel 2012-09-21 14:12:56 EDT
build: 0.328
Comment 2 Preethi Thomas 2012-09-24 15:57:36 EDT
verified
[root@pulp-master ~]# rpm -q pulp-rpm-server
pulp-rpm-server-0.0.328-1.fc17.noarch
[root@pulp-master ~]# 

> db.archived_calls.find()
>
Comment 3 Preethi Thomas 2013-01-07 09:10:02 EST
Pulp 2.0 released.

Note You need to log in before you can comment on or make changes to this bug.