Bug 857183 - Searching for the topics with the string "Note — Partitions" in the topic XML field causes an error.
Searching for the topics with the string "Note — Partitions" in the topic XML...
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 14:18 EDT by Stephen Gordon
Modified: 2013-07-01 19:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-01 19:51:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace (10.43 KB, text/plain)
2012-09-13 14:18 EDT, Stephen Gordon
no flags Details

  None (edit)
Description Stephen Gordon 2012-09-13 14:18:14 EDT
Created attachment 612539 [details]
Stack trace

Description of problem:

Searching for the topics with the string "Note — Partitions" in the topic XML field causes an error, I believe because of the unicode em dash. The error reported is as follows, I'll attach the stack trace:

javax.el.ELException: /WEB-INF/templates/TopicSearchListActionButtons.xhtml @9,75 rendered="#{render == null || render}": /CustomSearchTopicList.xhtml @237,84 value="#{not empty groupedTopicTagsList.resultList}": javax.persistence.PersistenceException: org.hibernate.exception.GenericJDBCException: could not execute query

The character is valid in topics (which as I understand it are stored as unicode) and therefore should be valid in search?

Additional info:
Comment 1 Lee Newson 2012-09-13 18:43:20 EDT
At an initial guess this is likely to be cause by the wrong collation on the database tables. Atm all the tables have "latin1_swedish_ci" and this appears to be the default value. However they should be using "utf8_general_ci", since all the data stored for topics should be UTF-8.

I'll look into this more.
Comment 2 Lee Newson 2012-11-22 23:21:50 EST
Fixed in build 20121123-1253.

Cause:

This is partly tied into Bug #869459. The other reason is mentioned above, in the the data wasn't being stored correctly.

Consequence:

Using certain characters would cause an exception to be thrown.

Fix:

Change the database/tables/columns to have the right encoding. Also see the fix for the bug mentioned above.

Note You need to log in before you can comment on or make changes to this bug.