Bug 857191 - Stacking shows a useless parent in All Available Subscriptions tab
Stacking shows a useless parent in All Available Subscriptions tab
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: 771481 840993
  Show dependency treegraph
 
Reported: 2012-09-13 14:35 EDT by Matt Reid
Modified: 2013-02-21 03:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:56:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Useless Parents (60.13 KB, image/png)
2012-09-13 14:36 EDT, Matt Reid
no flags Details
stacking parents (82.13 KB, image/png)
2012-11-28 12:16 EST, J.C. Molet
no flags Details

  None (edit)
Description Matt Reid 2012-09-13 14:35:57 EDT
Description of problem:
Using sub-man-1.0.17-1, I registered to stage using stacking-stage, and when I go to the All Available Subscriptions tab, I see 3 separate subscriptions, each with a parent. As far as I can tell, there is no benefit to having that parent there, you can't interact with the top level, and there's only one subscription per, so it isn't actually bundling things together.

It'd be nice if we could do away with the useless headers and just have the subscriptions listed there, taking up 3 rows instead of 6.

I assume this is due to stacking, since I've never seen subscriptions handled this way, and all 3 of those subscriptions are stackable. I don't think there are any non-stackable subs in there to compare against.
Comment 1 Matt Reid 2012-09-13 14:36:39 EDT
Created attachment 612571 [details]
Useless Parents
Comment 2 William Poteat 2012-10-26 07:48:34 EDT
master commit 7e0005a5691553aca1e42f8ff7e2837515b94962
Comment 5 J.C. Molet 2012-11-28 12:16:36 EST
Created attachment 653628 [details]
stacking parents

Tested with: subscription-manager-gui-1.1.10-1.el6.x86_64

As you can now see from the screen shot, stacking subscriptions with unique stacking IDs, seen here as "Red Hat Enterprise Linux Server, Standard (1-2 sockets) (Up to 4 guests)" and "Red Hat Enterprise Linux Server, Standard (1-2 sockets) (Up to 1 guest)"  have no parent in the list.

The old functionality, however, has been retained for multiple items sharing the same stacking ID.

Marking VERIFIED.
Comment 7 errata-xmlrpc 2013-02-21 03:56:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.