Bug 857195 - install-num-migrate-to-rhsm man page updates
install-num-migrate-to-rhsm man page updates
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Deon Ballard
John Sefler
: Documentation
Depends On:
Blocks: 771748 840993
  Show dependency treegraph
 
Reported: 2012-09-13 14:51 EDT by Alex Wood
Modified: 2013-01-09 13:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 854357
Environment:
Last Closed: 2013-01-07 23:03:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 RHEL Product and Program Management 2012-09-13 15:08:21 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 John Sefler 2012-10-19 11:40:55 EDT
Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.23-1.el5


[root@jsefler-rhel59 ~]# man -P cat install-num-migrate-to-rhsm
install-num-migrate-to-rhsm(8)                  install-num-migrate-to-rhsm(8)



NAME
       install-num-migrate-to-rhsm  -  Checks  the installation number
       for a system and installs the  required  product  certificates.
       This is used for migrating an offline system to Customer Portal
       Subscription Management.


SYNOPSIS
       install-num-migrate-to-rhsm [--dryrun|--instnum=NUMBER|--help]


DESCRIPTION
       install-num-migrate-to-rhsm migrates a system using legacy  Red
       Hat Enterprise Linux installation numbers to the X.509 certifi-
       cates used by Customer Portal Subscription Management.


       While  the  install-num-migrate-to-rhsm  script  performs   the
       migration  operation,  the data used to map the channels to the
       corresponding product certificates is defined in the  subscrip-
       tion-manager-migration-data  package. The subscription-manager-
       migration-data package must be installed  before  the  install-
       num-migrate-to-rhsm script can be run successfully.


BACKGROUND
       Access  to  support  and  updates  for  products  is determined
       through subscriptions.  Subscriptions are applied to a  system,
       which means that the system has the right to install and update
       a product with full support. Even disconnected or offline  sys-
       tems  still  need a way to track the products installed on them
       and the subscriptions used by them. In the older Red  Hat  Net-
       work  Classic  model  of  subscription management, a system was
       associated with a channel.   In  Customer  Portal  Subscription
       Management, installed products and subscriptions are identified
       through X.509 certificates.  Either way, a channel  or  a  cer-
       tificate provides a means of recognizing and tracking the prod-
       ucts and subscriptions for a system, even an offline system.


       When Red Hat software is purchased through a vendor,  the  pur-
       chased  software is identified in a installation number or sub-
       scription number.  Installation numbers are described  more  in
       the       Knowledgebase      article:      <https://access.red-
       hat.com/kb/docs/DOC-15408>


       This number is located  in  the  /etc/sysconfig/rhn/install-num
       file.  The  installation number is in essence a code which con-
       tains all of the information about the  products  and  versions
       purchased for the system. For example, this installation number
       shows that it is valid for RHEL  Client  and  RHEL  Workstation
       channels.
       [root@server ~]# python /usr/lib/python2.4/site-packages/instnum.py da3122afdb7edd23
       Product: RHEL Client
       Type: Installer Only
       Options: Eval FullProd Workstation
       Allowed CPU Sockets: Unlimited
       Allowed Virtual Instances: Unlimited
       Package Repositories: Client Workstation

       key: 14299426 "da3122"
       checksum: 175 "af"
       options: 4416 "Eval FullProd Workstation"
       socklimit: -1 "Unlimited"
       virtlimit: -1 "Unlimited"
       type: 2 "Installer Only"
       product: 1 "client"

       {"Workstation": "Workstation", "Base": "Client"}


       For  an  offline system, one which is not connect to either Red
       Hat Network Classic (Hosted) or a Satellite system, the instal-
       lation  number  can be used to move the subscription configura-
       tion from the older channel-based subscription  model  to  cer-
       tificate-based Customer Portal Subscription Management, managed
       by Subscription Manager.


       install-num-migrate-to-rhsm identifies the channel that a  dis-
       connected  system is subscribed to and then installs the appro-
       priate product certificates.


OPTIONS
       -h, --help
              Prints the specific help information for the given  com-
              mand.


       -d, --dryrun
              Performs  a  dry  run of the script. This indicates what
              product   certificates   will   be   copied   into   the
              /usr/share/rhsm/product directory, but does not actually
              install them.


       -i NUMBER, --instnum=NUMBER
              Migrates the channels and product certificates based  on
              the manually-entered installation number rather than the
              number in /etc/sysconfig/rhn/install-num.   This  is  an
              advanced  option;  most migrations will use the standard
              installation number in the system configuration.


USAGE
       To pull in the product certificates  and  migrate  the  system,
       simply run the command:

       [root@server ~]# install-num-migrate-to-rhsm


       The script installs the product certificates that correspond to
       the available  channels  from  the  installation  number.  This
       script  does not register the system or apply new subscriptions
       to the system. For the procedure to register an offline  system
       with Customer Portal Subscription Management and apply entitle-
       ments,    see    the     Customer     Portal     documentation:
       <https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Cus-
       tomer_Portal/1/html/Red_Hat_Network_Certificate-based_Subscrip-
       tion_Management/managing-consumers.html#web-consumer-register>


       After  migration,  the  system facts maintained by Subscription
       Manager display what script was used for migration.

       [root@server ~]# subscription-manager facts --list | grep migr
       migration.migrated_from: install_number


       Because the install-num-migrate-to-rhsm command does not regis-
       ter  the  system  with  Certificate-based  Red Hat Network, the
       migration facts do not include a new system ID.



FILES
       /etc/sysconfig/rhn/install-num
              The 16-character activation key issued by a vendor which
              contains all of the subscription and product information
              for the system. This is  used  during  the  installation
              process.


       /etc/sysconfig/rhn/systemid
              The digital server ID for this machine if the system has
              been registered with Red Hat Network Classic.  This file
              does not exist otherwise.


       /etc/sysconfig/rhn/up2date
              The  common  configuration  file used by RHN client pro-
              grams.


       /var/log/rhsm/rhsm.log
              The Subscription Manager log  file.  This  contains  any
              errors  registering  the system to Certificate-based Red
              Hat Network or with applying the system to entitlements.


       /etc/rhsm/facts/migration.facts
              The  file which contains the migration information. This
              is displayed as one of the system facts by  Subscription
              Manager.


       subscription-manager-migration-data.rpm
              The  package  which contains the mappings for the migra-
              tion script to migrate channels to the appropriate prod-
              uct certificates.


SEE ALSO
       install-num-migrate-to-rhsm(8), subscription-manager(8).



AUTHORS
       Alex Wood <awood@redhat.com>


BUGS
       Report bugs to <http://bugzilla.redhat.com>.


COPYRIGHT
       Copyright © 2011 Red Hat, Inc.


       This  is  free software; see the source for copying conditions.
       There is NO warranty; not even for MERCHANTABILITY  or  FITNESS
       FOR A PARTICULAR PURPOSE.



Version 0.3                    September 5, 2012install-num-migrate-to-rhsm(8)
[root@jsefler-rhel59 ~]# 



(In reply to comment #0)
> Name:
> Checks the installation number for a system and copies over the required
> product certificates.
> copies over -> installs
VERIFIED

> This is used for migrating an offline system to Certificate-based Red Hat
> Network.
> Cert-based RHN -> Red Hat Subscription Management
VERIFIED: was actually changed to "Customer Portal Subscription Management"

> Description:
> install-num-migrate-to-rhsm migrates... used by Certificate-based Red Hat
> Network.
> Cert-based RHN -> Red Hat Subscription Management
VERIFIED: was actually changed to "Customer Portal Subscription Management"

> Background:
> Subscriptions are assigned to a system... -> Subscriptions are attached to a
> system.
FAILED-QA: was actually changed to "Subscriptions are applied to a system"
The verb "applied" is not what was requested and is not used in the GUI.  In the GUI, the msgid "Attaching subscriptions" is used.

> In the new Certificate-based Red Hat Network ... -> Red Hat Subscription
> Management
VERIFIED: was actually changed to "Customer Portal Subscription Management"

> For an offline system... to the Certificate-based Red Hat Network
> subscription model, managed by Subscription Manager.
> Certificate-based Red Hat Network -> Red Hat Subscription Management
VERIFIED: was actually changed to "certificate-based Customer Portal Subscription Management"

> Options:
> -d, --dryrun
> This indicates what product certificates will be copied into the
> /usr/share/rhsm/produt directory, but does not actually copy them over.
> copy -> install
FAILED-QA: still uses the verb "copied"

> Usage:
> The script copies in the product certificates that correspond to the
> available channels from the installation number.
> copies in -> installs
VERIFIED

> This script does not register the system or subscribe the system to any
> entitlements.
> subscribe the system to any entitlements -> attach any subscriptions to the
> system.
FAILED-QA: was changed to "apply new subscriptions to the system."

> For the procedure to register an offline system with Certificate-based Red
> Hat Network and assign entitlements, see the RHN documentation:
> Certificate-based Red Hat Network -> Red Hat Subscription Management
VERIFIED: was actually changed to "Customer Portal Subscription Management"

> assign entitlements -> attach subscriptions
FAILED-QA: was actually changed to "apply entitlements"

> Replace the current URL with:
> https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Customer_Portal/1/
> html/Red_Hat_Network_Certificate-based_Subscription_Management/managing-
> consumers.html#web-consumer-register
VERIFIED

> Because the install-num-migrate-to-rhsm command does not register the system
> with Certificate-based Red Hat Network...
> Certificate-based Red Hat Network -> Red Hat Subscription Management
FAILED-QA: was not changed

> Files:
> /var/log/rhsm/rhsm.log
> This contains any errors registering the system to Certificate-based Red Hat
> Network or with subscribing the system to entitlements. ->
> This contains any errors registering the system to Red Hat Subscription
> Management or with attaching subscriptions to the system.
FAILED-QA: was not changed



Moving to ASSIGNED/FailedQA  (notice that mreid favors the phrase "attach subscriptions" rather than "apply entitlements".)
Comment 4 Deon Ballard 2012-10-23 17:21:13 EDT
In master:
commit 9b6ad9c768c61a674b44da07c11fbcda2782e1e4
Comment 5 John Sefler 2012-10-25 11:06:24 EDT
Verifying Version...
[root@jsefler-rhel59 ~]# rpm -q subscription-manager
subscription-manager-1.0.24-1.el5


[root@jsefler-rhel59 ~]# man -P cat install-num-migrate-to-rhsm
install-num-migrate-to-rhsm(8)                  install-num-migrate-to-rhsm(8)



NAME
       install-num-migrate-to-rhsm  -  Checks  the  installation number for a
       system and installs the required product certificates.  This  is  used
       for  migrating  an offline system to Customer Portal Subscription Man-
       agement.


SYNOPSIS
       install-num-migrate-to-rhsm [--dryrun|--instnum=NUMBER|--help]


DESCRIPTION
       install-num-migrate-to-rhsm migrates a system  using  legacy  Red  Hat
       Enterprise  Linux  installation numbers to the X.509 certificates used
       by Customer Portal Subscription Management.


       While the install-num-migrate-to-rhsm script  performs  the  migration
       operation,  the  data  used  to  map the channels to the corresponding
       product certificates is defined in the subscription-manager-migration-
       data  package. The subscription-manager-migration-data package must be
       installed before the install-num-migrate-to-rhsm  script  can  be  run
       successfully.


BACKGROUND
       Access  to support and updates for products is determined through sub-
       scriptions.  Subscriptions are assigned or attached to a system, which
       means  that  the  system has the right to install and update a product
       with full support. Even disconnected or offline systems still  need  a
       way to track the products installed on them and the subscriptions used
       by them. In the older Red Hat Network Classic  model  of  subscription
       management,  a system was associated with a channel.  In Customer Por-
       tal Subscription Management, installed products and subscriptions  are
       identified  through  X.509  certificates.   Either way, a channel or a
       certificate provides a means of recognizing and tracking the  products
       and subscriptions for a system, even an offline system.


       When  Red  Hat  software  is purchased through a vendor, the purchased
       software is identified in a installation number or  subscription  num-
       ber.   Installation  numbers  are  described more in the Knowledgebase
       article: <https://access.redhat.com/kb/docs/DOC-15408>


       This number is located in the /etc/sysconfig/rhn/install-num file. The
       installation  number  is  in  essence a code which contains all of the
       information about the products and versions purchased for the  system.
       For  example, this installation number shows that it is valid for RHEL
       Client and RHEL Workstation channels.
       [root@server ~]# python /usr/lib/python2.4/site-packages/instnum.py da3122afdb7edd23
       Product: RHEL Client
       Type: Installer Only
       Options: Eval FullProd Workstation
       Allowed CPU Sockets: Unlimited
       Allowed Virtual Instances: Unlimited
       Package Repositories: Client Workstation

       key: 14299426 "da3122"
       checksum: 175 "af"
       options: 4416 "Eval FullProd Workstation"
       socklimit: -1 "Unlimited"
       virtlimit: -1 "Unlimited"
       type: 2 "Installer Only"
       product: 1 "client"

       {"Workstation": "Workstation", "Base": "Client"}


       For an offline system, one which is not connect to either Red Hat Net-
       work  Classic  (Hosted) or a Satellite system, the installation number
       can be used to move the  subscription  configuration  from  the  older
       channel-based  subscription model to certificate-based Customer Portal
       Subscription Management, managed by Subscription Manager.


       install-num-migrate-to-rhsm identifies the channel that a disconnected
       system is subscribed to and then installs the appropriate product cer-
       tificates.


OPTIONS
       -h, --help
              Prints the specific help information for the given command.


       -d, --dryrun
              Performs a dry run of the script. This indicates  what  product
              certificates will be installed into the /usr/share/rhsm/product
              directory, but does not actually install the  product  certifi-
              cates in the directory.


       -i NUMBER, --instnum=NUMBER
              Migrates  the  channels  and  product certificates based on the
              manually-entered installation number rather than the number  in
              /etc/sysconfig/rhn/install-num.   This  is  an advanced option;
              most migrations will use the standard  installation  number  in
              the system configuration.


USAGE
       To pull in the product certificates and migrate the system, simply run
       the command:

       [root@server ~]# install-num-migrate-to-rhsm


       The script installs the product certificates that  correspond  to  the
       available  channels from the installation number. This script does not
       register the system or attach new subscriptions to the system. For the
       procedure to register an offline system with Customer Portal Subscrip-
       tion Management and attach subscriptions, see the Customer Portal doc-
       umentation:              <https://access.redhat.com/knowledge/docs/en-
       US/Red_Hat_Customer_Portal/1/html/Red_Hat_Network_Certificate-
       based_Subscription_Management/managing-consumers.html#web-consumer-
       register>


       After migration, the system facts maintained by  Subscription  Manager
       display what script was used for migration.

       [root@server ~]# subscription-manager facts --list | grep migr
       migration.migrated_from: install_number


       Because  the install-num-migrate-to-rhsm command does not register the
       system with Customer Portal  Subscription  Management,  the  migration
       facts do not include a new system ID.



FILES
       /etc/sysconfig/rhn/install-num
              The  16-character  activation key issued by a vendor which con-
              tains all of the subscription and product information  for  the
              system. This is used during the installation process.


       /etc/sysconfig/rhn/systemid
              The  digital  server ID for this machine if the system has been
              registered with Red Hat Network Classic.  This  file  does  not
              exist otherwise.


       /etc/sysconfig/rhn/up2date
              The common configuration file used by RHN client programs.


       /var/log/rhsm/rhsm.log
              The  Subscription  Manager  log  file. This contains any errors
              registering the system to Customer Portal Subscription  Manage-
              ment or with attaching the system to subscriptions.


       /etc/rhsm/facts/migration.facts
              The file which contains the migration information. This is dis-
              played as one of the system facts by Subscription Manager.


       subscription-manager-migration-data.rpm
              The package which  contains  the  mappings  for  the  migration
              script  to migrate channels to the appropriate product certifi-
              cates.


SEE ALSO
       install-num-migrate-to-rhsm(8), subscription-manager(8).



AUTHORS
       Alex Wood <awood@redhat.com>


BUGS
       Report bugs to <http://bugzilla.redhat.com>.


COPYRIGHT
       Copyright © 2011 Red Hat, Inc.


       This is free software; see the source for copying  conditions.   There
       is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICU-
       LAR PURPOSE.



Version 0.3                    September 5, 2012install-num-migrate-to-rhsm(8)


(In reply to comment #3)
> > Background:
> > Subscriptions are assigned to a system... -> Subscriptions are attached to a
> > system.
> FAILED-QA: was actually changed to "Subscriptions are applied to a system"
> The verb "applied" is not what was requested and is not used in the GUI.  In
> the GUI, the msgid "Attaching subscriptions" is used.
VERIFIED: was changed to "Subscriptions are assigned or attached to a system"

> > Options:
> > -d, --dryrun
> > This indicates what product certificates will be copied into the
> > /usr/share/rhsm/produt directory, but does not actually copy them over.
> > copy -> install
> FAILED-QA: still uses the verb "copied"
VERIFIED

> > This script does not register the system or subscribe the system to any
> > entitlements.
> > subscribe the system to any entitlements -> attach any subscriptions to the
> > system.
> FAILED-QA: was changed to "apply new subscriptions to the system."
VERIFIED: was changed to "This script does not register the system or attach new subscriptions to the system."

> > assign entitlements -> attach subscriptions
> FAILED-QA: was actually changed to "apply entitlements"
VERIFIED

> > Because the install-num-migrate-to-rhsm command does not register the system
> > with Certificate-based Red Hat Network...
> > Certificate-based Red Hat Network -> Red Hat Subscription Management
> FAILED-QA: was not changed
VERIFIED: was actually changed to "Customer Portal Subscription  Management"

> > Files:
> > /var/log/rhsm/rhsm.log
> > This contains any errors registering the system to Certificate-based Red Hat
> > Network or with subscribing the system to entitlements. ->
> > This contains any errors registering the system to Red Hat Subscription
> > Management or with attaching subscriptions to the system.
> FAILED-QA: was not changed
VERIFIED: was actually changed to "This contains any errors registering the system to Customer Portal Subscription Management or with attaching the system to subscriptions."


Moving to VERIFIED.
Comment 7 errata-xmlrpc 2013-01-07 23:03:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.