Bug 8572 - Bugs in RedHat installation program
Bugs in RedHat installation program
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-18 11:29 EST by Sergey
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-19 12:09:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergey 2000-01-18 11:29:08 EST
Dear Sir
I have installed redhat 6.1 several times on several machines and met
many slight and SEVERE bugs in graphical installation program!



First BUG:
while installing  I create   / partition 100 Mb , and  /usr partion 1 Gb ,
and select packages on  ~400 Mb , installation program said  :
"you have no enough space" or something like this ,
so I couldn't proceed with installation.



Second BUG:
I had correct partion table. I created new ext2 partions
for Linux , pressed the button "next" , and then computer rebooted
immediately. I repeated the same operation two more times, but the
installation always crashed.
So , to install RedHat 6.1 I was forced to use third party software -
Parition Magic 4 for DOS to create new ext2 partitions for redhat
installation!
I installed RedHat in graphical mode , and did not try this situation with
text Disk Druid or fdisk
Here is my partition table at that moment:
---------------------
Fat32 primary(1-100)
Fat32 primary(101-400)
ext2 primary(401-566)
extended(567-783)
---------------------
extended : start cylinder 567 , end cylinder 783
next extended table (on 567 cylinder): unused 0 - 0 , extended 656-757
next extended table (on 656 cylinder): ext2 656-757 , extended 773-783
next extended table (on 773 cylinder): swap 773-783.
as you see , free space from 567 to 655 ,and from 758 to 772 cylinders.



Third bug:
Sometimes , when booting from installation CD , the Xserver wrote about
error, and installation started in text mode , but in 5 minutes, after
rebooting , there was no any errors and installation started in graphical
mode.



Fourth BUG:
After choosing partitions to format I click "next", then "back" , and
partitions that I chosed not to format are checked for formatting !!!
Thanks God I noticed that.



Fifth bug:
Installation program hasn't created mount points for my FAT32 partitions,
only wrote to /etc/fstab about them. Such things will confuse new to Linux
users.



Sixth bug:
There is no possibility to install LILO on both Master Boot Record
and / partition during the installation, why ???



Seventh bug:
I chose not to install TEX formatting tools , but when I clicked next
I saw checked for installation TEX fonts (17 Mb) !
(The same with print tools)



Eight:
My friend chose "Install KDE workstation", but after installation GNOME
started.
I don't remember whether KDE was installed, but who can think that if the
user choose install KDE workstation  he wants GNOME by default?


Nine:
After choosing non-default keyboard I clicked "next" then "back" , and
keyboard changed to default.




Tenth bug:
The possibility to install in graphical mode without mouse are limited ,
in the screen of choosing individual packages to install ( looks like
GnoRPM)
there is no possibility to choose packages without mouse!


Eleventh bug:
In text mode installation there is no help about packages , one can say
that it is not a bug,in this case it is a very bad feature.



Sincerely yours
with 11 bugs
Sergey
Comment 1 Riley H Williams 2000-01-19 08:30:59 EST
Just some comments on your bug reports...

 Q> First BUG:
 Q> while installing  I create   / partition 100 Mb , and  /usr partion 1 Gb ,
 Q> and select packages on  ~400 Mb , installation program said: "you have not
 Q> enough space" or something like this , so I couldn't proceed with
 Q> installation.

Note that the space limit here was almost certainly the / partition, which is
rather small at 100 Mb. As a result, this probably isn't a bug as such.

However, it would be a definate improvement if the error message actually stated
how much space was required on each partition, and also indicated which
partitions it believed were too small.

 Q> Fifth bug:
 Q> Installation program hasn't created mount points for my FAT32 partitions,
 Q> only wrote to /etc/fstab about them. Such things will confuse new to Linux
 Q> users.

I remember reporting this to RedHat over a year ago, and the response received
was along the lines of "nobody's going to install Linux on FAT32 partitions, so
that's not needed." I was less than amused...

 Q> Sixth bug:
 Q> There is no possibility to install LILO on both Master Boot Record
 Q> and / partition during the installation, why ???

Probably because it isn't needed - if LILO is installed on the Master Boot
record, it never reads the boot sector of the boot partition (note that the boot
partition is not necessarily the / partition).

However, there IS a related bug here: If the option to install LILO on the boot
partition is chosen and the disk was unformatted prior to doing so, then the
disk remains unbootable since there is then no boot code in the Master Boot
record.

Note that this option may need to be chosen if one intends to install other
operating systems, since at least one insists on overwriting the boot code in
the Master Boot record with its own code.

 Q> Eight:
 Q> My friend chose "Install KDE workstation", but after installation GNOME
 Q> started. I don't remember whether KDE was installed, but who can think
 Q> that if the user choose install KDE workstation he wants GNOME by default?

There's one obvious mistake there: If GNOME started, then GNOME was installed.
Therefore, your friend chose to install BOTH KDE and GNOME - they are seperately
selectable.

Note that when Linux starts up, it has to give some sort of priority to the
different display managers when more than one is installed. It happens to give
higher priority to GNOME than KDE, but that can be changed by editing a single
file.

 Q> Nine:
 Q> After choosing non-default keyboard I clicked "next" then "back" , and
 Q> keyboard changed to default.

This is a known bug, and there's quite an extensive collection of bug reports
here on bugzilla regarding it. You might wish to read some of them.

 Q> Eleventh bug:
 Q> In text mode installation there is no help about packages , one can say
 Q> that it is not a bug,in this case it is a very bad feature.

I'm not sure why this was taken out, but it was definately present in 6.0 and
its removal is definately a step backwards.

One fairly simple work-around is to press ALT-F2 during the install to switch to
the text console, then type the following commands:

    cd /mnt/source/RedHat/RPMS
    rpm -qip XXXX

...where XXXX is the name of the package in question. You will then see the
relevant text displayed on this screen, and can then press ALT-F1 to switch back
to the installation screen.

I've omitted the other bugs in your report as I have no comments on them.
However, you may wish to note that the useful way to report bugs is in the form
of one bug per report, as different bugs often need to be directed to different
maintainers. Since you sent them all in one message, they will go to just one
maintainer who may choose not to forward them to other relevant maintainers.
Comment 2 Jay Turner 2000-04-21 11:46:59 EDT
First bug is not a bug - the system needs more than 100M on the root partition.
Forth bug is fixed in the latest installer.
Second is fixed in the latest installer.
Fifth bug fixed in the latest installer.
Sixth is not a bug; if you perform a custom installation, this option is
available to you.
Seventh if not a bug either; you selected another package which required the TEX
tools and therefore they were pulled in as dependency.
Eigth is fixed in the latest installer.
Tenth: the GIU installer is really meant to be used with a mouse; the text
installer is there for people that do not have a mouse.
Eleventh is fixed in the latest installer.

Other issues about going forward and back and things changing are being
addressed in forthcoming installer.
Comment 3 Michael Fulbright 2000-09-19 12:09:31 EDT
I am going to split this out into several bugs, as it is impossible to address
all of them in a single report.


Note You need to log in before you can comment on or make changes to this bug.