Bug 857220 - [enhancement]: Add "system restart" command for managing version upgrades
Summary: [enhancement]: Add "system restart" command for managing version upgrades
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: mainline
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: ---
Assignee: Kaushal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-13 20:00 UTC by Joe Julian
Modified: 2018-11-20 09:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-20 09:08:34 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github 586 0 None None None 2018-11-20 09:34:25 UTC

Description Joe Julian 2012-09-13 20:00:01 UTC
The current sysvinit/upstart/systemd script method of restarting (or not restarting) glusterfsd instances (bricks) produces very high load if successful, or doesn't restart bricks at all leaving them running older versions.

I propose a new "system" command:

gluster system restart [target_load=2] [nfs=false]

It would gracefully kill single bricks, and re-spawn them, waiting to proceed to the next one until the system load fell below target_load. It would also kill and restart the self-heal daemon and if nfs=true, the nfs daemon. Once it's finished all of those, can it reload itself?

Comment 1 Kaleb KEITHLEY 2015-10-22 15:46:38 UTC
because of the large number of bugs filed against mainline version\ is ambiguous and about to be removed as a choice.

If you believe this is still a bug, please change the status back to NEW and choose the appropriate, applicable version for it.

Comment 2 Niels de Vos 2015-12-01 12:25:05 UTC
Feature requests are only valid against the 'mainline' version. Once patches have been posted, it might be possible to get them backported, and at that time you can request a backport for a certain current version (clone this bug, or ask on irc/mailinglist).

Comment 3 Vijay Bellur 2018-11-20 09:33:23 UTC
Migrated to github:\n\nhttps://github.com/gluster/glusterfs/issues/586\n\nPlease follow the github issue for further updates on this bug.

Comment 4 Vijay Bellur 2018-11-20 09:34:25 UTC
Migrated to github:

https://github.com/gluster/glusterfs/issues/586

Please follow the github issue for further updates on this bug.


Note You need to log in before you can comment on or make changes to this bug.