Bug 857229 - RC3-Alpha Xfce spin: yumex doesn't open (polkit authentication dialog fails to pop-up) on live-cd.
RC3-Alpha Xfce spin: yumex doesn't open (polkit authentication dialog fails t...
Status: CLOSED DUPLICATE of bug 834494
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 16:27 EDT by Sergio
Modified: 2012-09-19 10:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 10:38:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio 2012-09-13 16:27:54 EDT
Description of problem: running live-cd the polkit authentication dialog doesn't pop-up when launching yumex so it doesn't work.


Version-Release number of selected component (if applicable): F18 RC3-Alpha Xfce spin, yumex 3.0.6


How reproducible: always here, but my system is very old with 1GB memory and although I'm careful with the testing I see that these F18 early spins really overload it so I don't know if it influences or not.

Steps to Reproduce: see description.
1.
2.
3.
  
Actual results: see description.


Expected results: polkit authentication dialog should pop-up or as there's no root password on live-cd then yumex maybe should work right away.


Additional info:
Comment 1 Bill Nottingham 2012-09-14 12:24:29 EDT
Does it silently fail, or...?
Comment 2 Sergio 2012-09-14 12:32:45 EDT
This is how yumex works in a F17 installation:
http://www.zimagez.com/zimage/screenshot-09142012-012835pm.php

On the live-Cd, since there's no password for root, yumex is stuck on that screen but *without the authentication box*.
yumex is there waiting so I think it's some polkit issue that in the live environment should allow yumex without asking for password (maybe, I don't understand about this).
Comment 3 Tim Lauridsen 2012-09-14 13:16:47 EDT
It looks like you are hit by this one

https://bugzilla.redhat.com/show_bug.cgi?id=834494

if the liveuser is not member of the wheel group, then polkit don't work and is hanging.

su -
usermod -G liveuser,wheel liveuser

should make it work
Comment 4 Sergio 2012-09-18 16:40:48 EDT
Just confirming that that makes it work.
Comment 5 Tim Lauridsen 2012-09-19 10:38:03 EDT

*** This bug has been marked as a duplicate of bug 834494 ***

Note You need to log in before you can comment on or make changes to this bug.