Bug 857243 - redhat-lsb has bogus dependencies
redhat-lsb has bogus dependencies
Status: CLOSED DUPLICATE of bug 835919
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-lsb (Show other bugs)
6.3
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 18:10 EDT by matthew patton
Modified: 2012-12-04 11:29 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 11:27:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matthew patton 2012-09-13 18:10:35 EDT
Description of problem:

redhat-lsb has 'gettext' as a dependency but I can't find any reason for it. This 'gettext' dependency further sucks in 'cvs'.

worse, redhat-lsb has a dependency on 'redhat-lsb-graphics' which sucks in a HUGE list of X11 and graphics related items. This totally pollutes a non-gui server whose only sin was to want to run tomcat6 (see 844307) or some other non-core software that wanted to use the LSB init-script stubs. In my case 'tomcat6' was a prerequisite for Spacewalk.

This bogus dependency tree is the reason for 835919 as well.

Version-Release number of selected component (if applicable):

4.0-3.el6

How reproducible:

every time

Steps to Reproduce:
1. yum install redhat-lsb
  
Actual results:

nearly 100 unnecessary packages installed chained via redhat-lsb-graphics

Expected results:

exactly 1 installed

Additional info:
Comment 2 Ondrej Vasik 2012-12-04 11:27:47 EST
Thanks for report and suggestion.
gettext utility is required in LSB core - see http://refspecs.linuxbase.org/LSB_4.1.0/LSB-Core-generic/LSB-Core-generic/gettext.html . I'm afraid it has to be there...
Dependency on cvs in gettext was dropped in Fedora while ago, maybe you could file a request to drop this dependency in RHEL-6 as well. Not much I can change in redhat-lsb package. Sorry...

About the redhat-lsb-graphics, there is a request for the package split, which should allow the redhat-lsb-core to be standalone package (for just the LSB core compliance, not the full (printing, graphics) compliance). This was already reported by other bugzilla #835919 - which you already mentioned... therefore closing this one as duplicate of it.

*** This bug has been marked as a duplicate of bug 835919 ***
Comment 3 Ondrej Vasik 2012-12-04 11:29:39 EST
Btw. your expected results: Exactly 1 package installed are definitely not reachable - reason for the redhat-lsb-* packages is to pull in all dependencies required on the LSB compliant system - so you can install minimal RHEL and redhat-lsb and you should have LSB compliant system (with redhat-lsb-core , LSB compliant for core tests).

Note You need to log in before you can comment on or make changes to this bug.