Bug 857254 - lightdm: shutdown/restart menus empty/non-functional
lightdm: shutdown/restart menus empty/non-functional
Status: CLOSED DUPLICATE of bug 872797
Product: Fedora
Classification: Fedora
Component: lightdm (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On: 867924 872797
Blocks: F18Xfce
  Show dependency treegraph
 
Reported: 2012-09-13 19:13 EDT by Sergio
Modified: 2012-11-10 22:13 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-10 22:13:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sergio 2012-09-13 19:13:49 EDT
Description of problem: F18 RC3-Alpha Xfce spin running live.
On the lightdm login screen the power menu that should show shutdown/reboot/suspend is empty.

Version-Release number of selected component (if applicable):


How reproducible: always.


Steps to Reproduce:
1. boot live-cd to lightdm screen.
2.
3.
  
Actual results: 'power' menu empty.


Expected results: 'power' menu functional.


Additional info:
Comment 1 Christoph Wickert 2012-10-03 06:39:26 EDT
I see the same with lightdm-1.3.3-2 and lightdm-gtk-1.3.1-1 on Fedora 17. So it is not the Fedora releases that has changed but lightdm internals.
Comment 2 Sergio 2012-10-28 16:19:57 EDT
Sorry for my ignorance and spamming but reading this gnome-shell issue at https://bugs.freedesktop.org/show_bug.cgi?id=53905 I thought if it couldn't be some ConsoleKit induced conflict that disables the power options.
Comment 3 Rex Dieter 2012-10-29 16:06:30 EDT
confirmed with both -gtk and -kde greeters, I suspect some consoleKit fail going on, investigating...
Comment 4 Rex Dieter 2012-10-29 16:50:22 EDT
apparently all ConsoleKit-related calls are returning insufficient permissions,

for example,
return ck_call_function ("CanStop", FALSE, NULL);

and even when I comment out the CanStop check, and allow the UI buttons to show, they don't work.
Comment 5 Rex Dieter 2012-10-29 16:53:18 EDT
Reassigning to ConsoleKit, any clues why lightdm greeter calls to ConsoleKit dbus methods 
org.freedesktop.ConsoleKit.Manager.CanRestart
org.freedesktop.ConsoleKit.Manager.CanStop
are returning false?
Comment 6 Rex Dieter 2012-10-29 16:54:00 EDT
Reassigning to ConsoleKit, any clues why lightdm greeter calls to ConsoleKit dbus methods 
org.freedesktop.ConsoleKit.Manager.CanRestart
org.freedesktop.ConsoleKit.Manager.CanStop
are returning false?
Comment 7 Rex Dieter 2012-10-29 18:48:11 EDT
In the meantime, looks like implementing the lightdm systemd shutdown/restart bits may be worth doing now (bug #867924)
Comment 8 Kevin Kofler 2012-10-29 19:26:10 EDT
Yeah, as I said, ConsoleKit should already be dead and gone, LightDM needs to stop beating a dead horse (or worse, trying to ride it ;-) ).
Comment 9 Christoph Wickert 2012-10-30 05:18:01 EDT
Thanks for this insightful comment, I am sure it will help us fixing the problem.
Comment 10 Rex Dieter 2012-11-03 07:32:02 EDT
looks like it's a policykit thing, and Tim Lauridsen is the hero for figuring that out, see bug #872797
Comment 11 Dan Mashal 2012-11-10 22:13:54 EST

*** This bug has been marked as a duplicate of bug 872797 ***

Note You need to log in before you can comment on or make changes to this bug.