Bug 857276 - glibc-common deletes any local locales on upgrade
glibc-common deletes any local locales on upgrade
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: glibc (Show other bugs)
6.3
All All
unspecified Severity urgent
: rc
: ---
Assigned To: Carlos O'Donell
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 21:50 EDT by Christoph Anton Mitterer
Modified: 2016-08-09 15:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-09 15:28:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Anton Mitterer 2012-09-13 21:50:14 EDT
Hi.

When locale locales are used, e.g. via:
localedef -i /usr/local/share/i18n/locales/foo_BAR -c -f UTF-8 foo_BAR.UTF-8
and glibc-common is upgrade any such locale locales get deleted.

Subsequently (on reboot) any services which strictly depend on these locales break utterly, e.g. postgresql when it uses such a locale in a database; therefore the high severity.


Please automatically re-generate also the locale locales, like e.g. Debian does since ages.


Cheers,
Chris.
Comment 2 Zdenek Kabelac 2012-09-24 04:57:11 EDT
It's not the first time my  /etc/localtime has disappeared after glibc upgrade.
After todays rawhide upgrade to

glibc-common-2.16.90-14.fc19.x86_64
glibc-2.16.90-14.fc19.x86_64

I've found out this link in  /etc

/etc/localtime.rpmnew -> ../usr/share/zoneinfo/US/Eastern

and my original  /etc/localtime  pointing to Europe/Prague was lost.

Is there any chance there will be upgrade process tested by the package maintainer before it kills rawhide user's machine?

So far the fix for my time issue was simple by adding localtime link by hand...
Comment 3 Jeff Law 2012-09-25 16:23:00 EDT
Zdenek, the problem you're referencing is completely and totally different than the original reporter.

The handling of /etc/localtime is in a state of flux, initially due to packaging changes within glibc itself and more recently due to moving the ownership/management of /etc/localtime to systemd for F18 and beyond.
Comment 12 Carlos O'Donell 2016-08-09 15:28:53 EDT
Red Hat Enteprise Linux 6.9 is in production phase 2, and as such only urgent priority bug fix errata will be considered. Red Hat engineering does not quality this bug as urgent. The behaviour has been present for the entire lifetime of RHEL6, and fixing it would require major restructuring of how locales are tested and deployed.

The solution is not to add the local locales to locale-archive and instead place the compiled locales in /usr/lib/locale which will be searched after the archive. Upstream Fedora is doing this to support C.UTF-8 outside of the locale-archive file.

Note You need to log in before you can comment on or make changes to this bug.