Bug 857282 - improve the warning message for dump target remain size checking
improve the warning message for dump target remain size checking
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kexec-tools (Show other bugs)
6.4
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Dave Young
Guangze Bai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 22:38 EDT by Dave Young
Modified: 2015-02-08 16:38 EST (History)
3 users (show)

See Also:
Fixed In Version: kexec-tools-2.0.0-249.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:48:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
improve warning message for remain size checking (3.74 KB, patch)
2012-09-23 23:17 EDT, Dave Young
no flags Details | Diff

  None (edit)
Description Dave Young 2012-09-13 22:38:54 EDT
Description of problem:

Copying from email content:

> > Hi have the customer using the following methodogy for kdump. Is this a best practice method? and what about the error he is seeing. What is our best practice in collection of kdumps, and also helpful to GSS when a customer interacts with support? 
> > 
> > "I have kdump enabled in the RHEL 6 Server build. I’ve added the following entry crashkernel=128M into the grub.conf file. I have the default entry core_collector makedumpfile -c --message-level 1 -d 31 in /etc/kdump.conf. I have /var/crash as the default target, with approximately 3.6 GB free. However, on the first reboot the kdump service says “There is not enough space to save a vmcore”. Yet, when I force a crash, the core dump is 45MB. Is it safe to ignore the 1-time message? "
> > 

In rhel7 we changed to warning to below:
"There might not be enough space to save a vmcore."

If user use core_collector such as 'cp' the original warning is right.
But for core_collector such as 'makedumpfile' which will compress and
exclude useless pages. This might be not right. We can not guarantee the
captured vmcore size is always small enough because this depends on the
1st kernel memory usage.

Change rhel6 warning to 'might not be' as what we do in rhel7 is better
currently.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dave Young 2012-09-23 23:17:19 EDT
Created attachment 616341 [details]
improve warning message for remain size checking
Comment 5 errata-xmlrpc 2013-02-21 02:48:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0281.html

Note You need to log in before you can comment on or make changes to this bug.