Bug 857328 - No symbols on the panel when activating
No symbols on the panel when activating
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-libpinyin (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peng Wu
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 02:52 EDT by Akira TAGOH
Modified: 2012-09-25 02:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 02:23:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2012-09-14 02:52:50 EDT
Description of problem:
When activating ibus-libpinyin, there are no symbols on panel.

Version-Release number of selected component (if applicable):
ibus-libpinyin-1.4.2-1.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1.add "Chinese (China) [GB2312] (Intelligent Pinyin)" on the input sources
2.click on the language panel or activate "Intelligent Pinyin" and see the panel
3.
  
Actual results:
no symbols

Expected results:
any symbols should appears

Additional info:
This is because libpinyin.xml doesn't have <symbol/> line. for instance, if "δΈ­" is supposed to be used for pinyin, you need to add "<symbol>&#x4e2d;</symbol>" into <engine/> for pinyin. need to add something for libbopomofo as well.
Comment 1 Peng Wu 2012-09-16 23:14:27 EDT
The code is modified in https://github.com/epico/ibus-libpinyin.
I will release ibus-libpinyin 1.4.92 soon.
Comment 2 Fedora Update System 2012-09-18 02:05:45 EDT
ibus-libpinyin-1.4.92-1.fc18,libpinyin-0.7.91-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-libpinyin-1.4.92-1.fc18,libpinyin-0.7.91-1.fc18
Comment 3 Fedora Update System 2012-09-18 15:19:48 EDT
Package ibus-libpinyin-1.4.92-1.fc18, libpinyin-0.7.91-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-libpinyin-1.4.92-1.fc18 libpinyin-0.7.91-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14250/ibus-libpinyin-1.4.92-1.fc18,libpinyin-0.7.91-1.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-09-19 00:30:30 EDT
ibus-libpinyin-1.4.92-1.fc17,libpinyin-0.7.91-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-libpinyin-1.4.92-1.fc17,libpinyin-0.7.91-1.fc17
Comment 5 Fedora Update System 2012-09-25 02:23:43 EDT
ibus-libpinyin-1.4.92-1.fc18, libpinyin-0.7.91-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.