Bug 857332 - Support BeakerRequires (in addition to RhtsRequires)
Support BeakerRequires (in addition to RhtsRequires)
Status: CLOSED WONTFIX
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
0.8
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Dan Callaghan
:
Depends On:
Blocks: 857090
  Show dependency treegraph
 
Reported: 2012-09-14 03:00 EDT by Petr Šplíchal
Modified: 2016-05-31 21:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 19:41:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2012-09-14 03:00:16 EDT
Description of problem:

Task hard requires are currently tracked in the metadata as
"RhtsRequires". As this still refers to the old test system we
should provide BeakerRequires and keep RhtsRequires for backward
compatibility. Well, the same probably applies for the package
name itself:

rhts-devel-4.50-1.el6eng.noarch
Comment 1 Dan Callaghan 2012-09-16 18:26:48 EDT
The phrase "rhts" appears in many other places too (all the scripts in rhts-test-env for example). I don't think it's worth changing them all, especially since we are planning to move away from being tied to RPMs for task packaging.

As I see it, the "rhts" here means "RHTS-format tests". Beaker will eventually support other task formats (such as Autotest control files) though we will probably continue supporting the RHTS format forever as well. So I think it makes sense to leave these names as is.

Petr, I will close this bug as WONTFIX unless you have any strong objections.

Note You need to log in before you can comment on or make changes to this bug.