Bug 857348 - crash when network online status changes
crash when network online status changes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: liferea (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
: Reopened
: 861557 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 03:44 EDT by Fabrice Bellet
Modified: 2012-10-09 06:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 06:02:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Disconnect signals when finalizing htmlview (2.21 KB, patch)
2012-09-14 03:44 EDT, Fabrice Bellet
no flags Details | Diff

  None (edit)
Description Fabrice Bellet 2012-09-14 03:44:45 EDT
Created attachment 612752 [details]
Disconnect signals when finalizing htmlview

liferea frequently crashes when manipulating htmlviews (opening/closing new tabs) while the network online status changes. This is caused because the signal notifying online status is not properly disconnected when the htmlview is removed. Suggested patch follows.
Comment 1 Yanko Kaneti 2012-09-14 05:50:27 EDT
This should probably be brought up in the upstream bug tracker.

Maybe the patch itself could be reduced to 
 static void
 liferea_htmlview_finalize (GObject *object)
 {
+       g_signal_handlers_disconnect_by_data (network_monitor_get (), object);
+
        G_OBJECT_CLASS (parent_class)->finalize (object);
 }

I don't use liferea tabs so I've not seen it crash like that. Could you test this?
Comment 2 Fabrice Bellet 2012-09-14 09:02:59 EDT
Yes. I stress tested it with your patch, and it seems it's stable too. Thanks!
Comment 3 Emmanuel Seyman 2012-09-14 09:08:12 EDT
Fabrice, have you submitted this to upstream's bug tracker?
Comment 4 Yanko Kaneti 2012-09-14 09:21:04 EDT
Thanks for testing. I've submitted this upstream.
https://sourceforge.net/tracker/?func=detail&aid=3567715&group_id=87005&atid=581686

Thinking of filing an update with this and 1.8.8
Comment 5 Fedora Update System 2012-09-14 09:55:03 EDT
liferea-1.8.8-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/liferea-1.8.8-1.fc18
Comment 6 Fedora Update System 2012-09-14 09:56:00 EDT
liferea-1.8.8-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/liferea-1.8.8-1.fc17
Comment 7 Fedora Update System 2012-09-17 13:52:37 EDT
Package liferea-1.8.8-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liferea-1.8.8-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14154/liferea-1.8.8-1.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-09-20 16:36:21 EDT
liferea-1.8.8-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-09-21 20:09:07 EDT
liferea-1.8.8-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Yanko Kaneti 2012-09-29 06:22:45 EDT
*** Bug 861557 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2012-09-29 06:30:34 EDT
liferea-1.8.8-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/liferea-1.8.8-2.fc17
Comment 12 Yanko Kaneti 2012-09-29 06:32:06 EDT
I forgot to actually apply the patch in the previous update. Sorry.
Comment 13 Fedora Update System 2012-09-29 22:27:40 EDT
Package liferea-1.8.8-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liferea-1.8.8-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15093/liferea-1.8.8-2.fc17
then log in and leave karma (feedback).
Comment 14 Yanko Kaneti 2012-10-09 06:02:43 EDT
The update already hit stable so I am closing again.

Note You need to log in before you can comment on or make changes to this bug.