Bug 857366 - Inconsistency in TTYs opened with new sessions
Inconsistency in TTYs opened with new sessions
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
:
: 921778 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 04:52 EDT by Martin Bříza
Modified: 2015-04-19 10:29 EDT (History)
9 users (show)

See Also:
Fixed In Version: kde-workspace-4.10.4-5.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 14:39:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The warning message displayed (37.10 KB, image/png)
2012-09-14 04:52 EDT, Martin Bříza
no flags Details

  None (edit)
Description Martin Bříza 2012-09-14 04:52:23 EDT
Created attachment 612776 [details]
The warning message displayed

Description of problem:
TTYs opened by new sessions from KDE are numbered inconsistently and not according to the warning message that is displayed prior to creating one.

Version-Release number of selected component (if applicable):
kde-workspace-4.8.5-2.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Create a new session (Kickoff -> Leave -> Switch user, then choose "New Session")
2. Log out of the new session, return in the default one
3. Create a new session again.
  
Actual results:
The first created session is in TTY2, the second one in TTY7

Expected results:
Same result, probably TTY2 as we have the first one on TTY1

Additional info:
It would also be nice if the warning message (in the attachment) contained the actual terminal numbers.
Comment 1 Martin Bříza 2013-06-12 07:16:51 EDT
*** Bug 921778 has been marked as a duplicate of this bug. ***
Comment 2 Martin Bříza 2013-06-13 06:27:48 EDT
This bug is addressed in kde-workspace Fedora package git commit 8b4cf74b4299256e8706249eae3de51df934a92f.
Very small change, not worth rebuilding the package and filing a new update. Will be obtained in the next update of the package.
Comment 3 Fedora Update System 2013-06-18 07:51:50 EDT
kde-workspace-4.10.4-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kde-workspace-4.10.4-5.fc19
Comment 4 Fedora Update System 2013-06-18 07:51:53 EDT
kde-workspace-4.10.4-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kde-workspace-4.10.4-5.fc19
Comment 5 Fedora Update System 2013-06-18 07:52:24 EDT
kde-workspace-4.10.4-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kde-workspace-4.10.4-5.fc18
Comment 6 Fedora Update System 2013-06-18 07:52:44 EDT
kde-workspace-4.10.4-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kde-workspace-4.10.4-5.fc17
Comment 7 Fedora Update System 2013-06-18 15:42:59 EDT
Package kde-workspace-4.10.4-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-workspace-4.10.4-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11185/kde-workspace-4.10.4-5.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-06-29 14:39:29 EDT
kde-workspace-4.10.4-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-06-30 21:43:01 EDT
kde-workspace-4.10.4-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Mathieu Jobin 2015-04-19 10:29:13 EDT
couldn't a better patch been made to detect current tty and display a message that mention the current and next tty. this could be merged upstream for all linux distribution.

Note You need to log in before you can comment on or make changes to this bug.