Bug 857382 - Introduce new systemd-rpm macros in polkit spec file
Introduce new systemd-rpm macros in polkit spec file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: polkit (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 850016
  Show dependency treegraph
 
Reported: 2012-09-14 05:10 EDT by Václav Pavlín
Modified: 2013-05-24 16:42 EDT (History)
1 user (show)

See Also:
Fixed In Version: polkit-pkla-compat-0.1-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 16:42:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Václav Pavlín 2012-09-14 05:10:30 EDT
Fedora 18 changes the way how to work with services in spec files. It introduces new macros - %systemd_post, %systemd_preun and %systemd_postun; which replace scriptlets from Fedora 17 and older (see https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd, https://bugzilla.redhat.com/show_bug.cgi?id=850016).
Comment 1 Fedora Admin XMLRPC Client 2013-02-01 18:59:31 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Miloslav Trmač 2013-05-10 21:02:52 EDT
Thanks for your report, added in polkit-0.110-4.fc19.

(The macros don't make _that_ much sense for polkit, because it is exclusively bus-activated - but they do the equivalent of (systemctl daemon-reload) which is needed, and hasn't been done before; so using them is overall beneficial.)
Comment 3 Fedora Update System 2013-05-10 21:04:00 EDT
polkit-pkla-compat-0.1-2.fc19, polkit-0.110-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/polkit-0.110-4.fc19,polkit-pkla-compat-0.1-2.fc19
Comment 4 Fedora Update System 2013-05-11 14:07:06 EDT
Package polkit-pkla-compat-0.1-2.fc19, polkit-0.110-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing polkit-pkla-compat-0.1-2.fc19 polkit-0.110-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7922/polkit-0.110-4.fc19,polkit-pkla-compat-0.1-2.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-05-24 16:42:33 EDT
polkit-pkla-compat-0.1-2.fc19, polkit-0.110-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.