Bug 857421 - sad GNOME if less monitors on resume than there were on suspend
sad GNOME if less monitors on resume than there were on suspend
Status: CLOSED DUPLICATE of bug 902316
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 07:19 EDT by Paolo Bonzini
Modified: 2013-02-11 13:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-11 13:57:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Bonzini 2012-09-14 07:19:42 EDT
Description of problem:
If a laptop is suspended with an external monitor, and resumed without, gdm will show the "sad GNOME" and require logout.

Version-Release number of selected component (if applicable):
gnome-shell-3.5.91-1.fc18.x86_64

Other possibly relevant packages:
gnome-screensaver-3.5.5-1.fc18.x86_64
mutter-3.5.91-2.fc18.x86_64
xorg-x11-drv-intel-2.20.6-1.fc18.x86_64
xorg-x11-server-common-1.13.0-3.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Dock laptop to a docking station with an external monitor
2. Suspend laptop (via Alt+Shutdown).
3. Undock laptop.
4. Resume laptop.
  
Actual results:
gdm requires you to logout.

Expected results:
I can get back into my session.

Additional info:
Comment 1 Christopher Beland 2013-02-11 13:57:02 EST
Also seen in Fedora 18 public release and reported separately.  Since this was in Rawhide, arbitrarily marking as duplicate and linking.

*** This bug has been marked as a duplicate of bug 902316 ***

Note You need to log in before you can comment on or make changes to this bug.