Bug 857425 - silence the rpmdiff warnings about versioned deps
Summary: silence the rpmdiff warnings about versioned deps
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreport
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: abrt
QA Contact: David Kutálek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-14 11:35 UTC by Jiri Moskovcak
Modified: 2015-02-01 22:55 UTC (History)
3 users (show)

Fixed In Version: libreport-2.0.9-12.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 07:54:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0290 0 normal SHIPPED_LIVE abrt, libreport and btparser bug fix and enhancement update 2013-02-20 20:55:47 UTC

Description Jiri Moskovcak 2012-09-14 11:35:38 UTC
Description of problem:

VERIFY	 	libreport	 	Subpackage libreport on all architectures consumes library libreport-compat from subpackage libreport-compat but does not have explicit package version requirement.<br/>Please add Requires: libreport-compat = %{version}-%{release} to libreport in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.

VERIFY	 	libreport	 	Subpackage libreport on all architectures consumes library libreport-plugin-reportuploader from subpackage libreport-plugin-reportuploader but does not have explicit package version requirement.<br/>Please add Requires: libreport-plugin-reportuploader = %{version}-%{release} to libreport in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.

VERIFY	 	libreport-compat	 	Subpackage libreport-compat on i686 ppc s390 consumes library libreport.so.0 from subpackage libreport but does not have explicit package version requirement.<br/>Please add Requires: libreport = %{version}-%{release} to libreport-compat in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.

VERIFY	 	libreport-compat	 	Subpackage libreport-compat on all architectures consumes library libreport-plugin-rhtsupport from subpackage libreport-plugin-rhtsupport but does not have explicit package version requirement.<br/>Please add Requires: libreport-plugin-rhtsupport = %{version}-%{release} to libreport-compat in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.

VERIFY	 	libreport-python	 	Subpackage libreport-python on all architectures consumes library libreport-plugin-rhtsupport from subpackage libreport-plugin-rhtsupport but does not have explicit package version requirement.<br/>Please add Requires: libreport-plugin-rhtsupport = %{version}-%{release} to libreport-python in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages.

VERIFY	 	libreport-compat	 	Subpackage libreport-compat on x86_64 ppc64 s390x consumes library libreport.so.0()(64bit) from subpackage libreport but does not have explicit package version requirement.<br/>Please add Requires: libreport = %{version}-%{release} to libreport-compat in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages


Version-Release number of selected component (if applicable):
libreport-2.0.9-9.el6

How reproducible:
100%

Expected results:
- no warnings from rpmdiff about deps

Comment 5 errata-xmlrpc 2013-02-21 07:54:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0290.html


Note You need to log in before you can comment on or make changes to this bug.