Bug 857434 - Logs:Apply filter on pretty view of log throws error on rhel
Logs:Apply filter on pretty view of log throws error on rhel
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Tzu-Mainn Chen
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 08:14 EDT by Rehana
Modified: 2012-12-04 10:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A new source_type variable for events caused Cloud Engine to display an error when viewing the Logs page. This fix filters events unrelated to applications and instance. Users now view the Logs page without error.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:19:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rails (12.42 KB, text/x-log)
2012-09-14 08:14 EDT, Rehana
no flags Details

  None (edit)
Description Rehana 2012-09-14 08:14:45 EDT
Created attachment 612833 [details]
Rails

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.install aeolus and run aeolus-configure
2.build and pushed image to mock
3.launched instance
4.Go to Cloud resource zone
5.Click on logs
6.Click on pretty view
7.Click on apply filter
  
Actual results:
Error "
PGError: ERROR: missing FROM-clause entry for table "applications" LINE 3: ... and source_id = Applicatio... ^ : SELECT "instances".* FROM "instances" WHERE (exists (select 1 from events where source_type = 'Application' and source_id = Applications.id and status_code = 'running' and event_time <= '2012-09-07 00:00:00') and not exists (select 1 from events where source_type = 'Application' and source_id = Applications.id and status_code = 'stopped' and event_time <= '2012-09-07 00:00:00')) "

Rails log attached

Expected results:
Should display the graph

Additional info:

rpm -qa | grep aeolus 
rubygem-aeolus-image-0.6.0-1.el6cf.noarch
aeolus-conductor-0.13.6-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
aeolus-all-0.13.6-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.6-1.el6cf.noarch
aeolus-conductor-daemons-0.13.6-1.el6cf.noarch

repo

[aeolus]
name=aeolus_nightly
baseurl=http://download.lab.bos.redhat.com/rel-eng/repos/cf-1.1-rhel-6-candidate/x86_64/
enabled=1
gpgcheck=0
Comment 3 Matt Wagner 2012-09-18 17:12:25 EDT
Pushed.

I did this wrong and pushed it to 1.1 directly, then master, so it's got two IDs:

On master:
commit ac53e813b4412edd79e4717a79904c3758ea890b
Author: Tzu-Mainn Chen <tzumainn@redhat.com>
Date:   Tue Sep 18 14:59:43 2012 -0400

    BZ857434 - since source_type is used to figure out table names, ensure that source_type is always equal to deployment or instance
    
    Signed-off-by: Matt Wagner <matt.wagner@redhat.com>



On 1.1 branch:
commit 2c7fe73913d51757ae8e27a45accb686be625209
Author: Tzu-Mainn Chen <tzumainn@redhat.com>
Date:   Tue Sep 18 14:59:43 2012 -0400

    BZ857434 - since source_type is used to figure out table names, ensure that source_type is always equal to deployment or instance
    
    Signed-off-by: Matt Wagner <matt.wagner@redhat.com>
Comment 5 Aziza Karol 2012-09-25 03:13:55 EDT
No error is thrown when clicked on Apply filter on pretty view of log.

verified:
rpm -qa | grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.7.2-1.el6cf.noarch
aeolus-conductor-doc-0.13.14-1.el6cf.noarch
aeolus-configure-2.8.7-1.el6cf.noarch
aeolus-all-0.13.14-1.el6cf.noarch
aeolus-conductor-0.13.14-1.el6cf.noarch
aeolus-conductor-daemons-0.13.14-1.el6cf.noarch
Comment 7 errata-xmlrpc 2012-12-04 10:19:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.